Homey Community Forum

Heatit Z-wave app (v2.6.1)

hi , i dont know how to add attachment so ive put it ind google drive: https://drive.google.com/open?id=1gXZJGVIEHzv2wNdpaGorLSKZRwYEbVVY

here is a log specific for adding a ztrm2fx , and excluding it again. maybe it can shed some light onto why the node is not removed when removing device (statys behind as unknown node, and is added with same device id when adding device later) update: when adding via generic zwave device, it will also remove itsef completely from the system successfully. the devices added with old version of ztrmfx2 would not be removed but linger as “unknown device”

the screenshot shows node ID.

node id 66 and 67 are ztrm2fx installed unsecure with the new beta.

here is log for removing node 59, which was included before the beta. this lingers now as unknown node. https://drive.google.com/open?id=1vQoE2M9axOSEpfN51cZi2M98M31TwBFT

here is complete log , after trying to include thermostat using new beta app. got error and no evice included. had not reset device before inclusion. devicewas not added in the end, as unknown node or otherwise

i can confirm firmware version 3.4

Hi How can i link z water and z trm2fx?

@Christer can you contact me on Slack for this topic? Let’s see how to get this solved, without flooding the forum topic.
One of the thing I do notice in the logs is that Node 72 is still included securely; whereas this should be blocked.

Hi @Nerohan_Selvendran, welcome to the community. To add the Z-Water and Z-TRM2fx, please install the BETA version of the Heatit app (2.4.0) and install the devices with Homey at close proximity to the devices (move Homey, not the devices).

Hi to use the waterborne heating i ned to link a relay in the trm2fx with z water. Like this in fibaro https://m.youtube.com/watch?v=GwuYtsjG0Kc

@Nerohan_Selvendran let’s create another entry into the FAQ…

Let me know if this is helpfull or if you still have questions to create the right setup.

Today I re-added my Z-TRM2fx thermostat with the new beta version app.
My first attempt ended with the status.Cannot destructure properly ‘wakeUpInterval’ of ‘undefined’ or null which creates an unkown device in developer options. The Zwave comms of this device are working. I removed it sucessfully using the settings-zwave-remove device option and put the thermostat in inclusion mode again (to start exclusion).

No need for homey restart or thermostat factory reset.

My second attempt was succesfull, the only thing that was a bit strange is the thermostat: it replied with ERR in the display instead of the expected “INC”. But it works like a charm. Communication figures in dev-tools look normal now, it used to be way out of line compared to the other zwave devices.

Many thanks for your efforts.

1 Like

Based on all the positive feedback, I’ve decided to promote the BETA branch to stable.
With a minor change to finalize the preparation for ‘Energy’ (Homey 3.0.0).

As always, pending Athom’s app store approval:

1 Like

Thanks @TedTolboom for the Beta and the work you have done now with fixing the issues. I have put all of my 10 heatit termostats over and now they are (finally) working as they were supposed to
:blush:
I will donate for your work :+1:

Thank you @Torill_Iversen for you feedback and contribution. Much appreciated!

Thanks for the new update. I have been testing it for 2 weeks now without any dropout of the thermostats. I only had some issues adding it to the homey, but after some resets and remove any node on homey, I could add it.

1 Like

Hi,

I have a new homey (late 2019) and the latest app versjon. I amtrying to pair my z-trm2fx but all i get is «err» on the thermostat and the pairing times out on the homey.

  • I have tried moving the homey closer (0-100cm)
  • i have tried to factory reset the thermostats

Any ideas? Is it just to keep on trying…?!?

Did u try this?

1 Like

Hi,

I had not tried this (had not found it in the forum), but it worked. Here is what worked for me:

  • followed step 1 and 1a here: Adding a Z-wave device to Homey [Howto]
  • factory resetted all thermostats
  • some would include right away. Some would not
  • those who would not include: factory reset thermostat and try again. Repeat untill it was found and included

Ps: held the Homey into the thermostat.

Thank you for your help!

Cheers. That’s what a community is for aye!

1 Like

Hello. Does anybody knows if it is possible to connect digital DS18B20 temperature sensor to Heatit thermostat? There is no official connector, but may be there is some pins on the board?

I have a fem Heatit z-push Button 4. It looks like it is not supported at the moment. Are you planning to support this as well?

2 Likes

Hello Community,

Is it possible to set the actual temperature to an external sensor or a variable instead of the internal/connected sensor. I would like to sent the average temperature of different sensors of one floor to the thermostat.

Regards
Andreas

2 Likes

Hi, and thanks for a great app.

My apologies if this has been covered already, but I have a question about the ‘Energy’ functionality. I’m running app version 2.4.0 and I see there is a “Constant power usage” parameter in settings, I assume this is for setting the size of the heating element (in my case underfloor heating). But in Homey Energy tab this power is reported continuously regardless of heating state. I.e. it appears as if full power is consumed also when the thermostat is not engaged.

Am I doing something wrong or is the correct version yet to be deployed?

Cheers
Frode

I have the same request…