Homey Community Forum

Heatit Z-wave app (v2.7.0)

Thanks for the feedback.
It took some time and effort to investigate the cause. I’m confident that it will solve the majority of issues.

Looking forward to your experience; please also mention the setup (quantity and type of devices) you use at home.

It took some effort to exclude the device. Several resets and several excluding cycles. But… after that the device was included in no time. Thank @TedTolboom

Off subject: is there a way to periodically reset the KWH meter?

1 Like

Thanks for the update.
Did a reset on all 10 we have at home. Removed them from Homey and added again.
When adding the thermostat went all the way thru it’s add cycle and came up with Err and then hopped to Incl. The app was already showing the device befor the error code appeared.

For the first time we have control over our floorheating :slight_smile: Thanks!!

1 Like

Great, thanks for the feedback!

1 Like

Forgot.
Have Homey PRO, 2 z-wave repeaters, only Z-wave devices. 10 Heatit trm2fx thermostats

Thank you so much for looking into this Ted!
We have 8 Z-TRM2fx thermostats and the regular Homey in our weekend home. Thermostats where added using the new beta version and they seems to be working better than before.

1 Like

Thanks for the feedback! Much appreciated.

Hello, thanks for looking in to the issue. I have 3 Z-TRM2fx and when trying to add 2 of them I get som strange error.

I tried to reset thermostats several times and also resetting Z-wave network without success. I can see in developer that they are visible but still unknown.

Things I tried:
Following your procedure
Resetting Z-TRM2fx
Remove any device in Z-wave developer and the running inclusion / exclusion on Z-TRM2fx
Resetting Z-wave network on Homey

Any other things I should try?

@Andren just to check; you’re running on the BETA branch of the app (v2.3.0)?
When the device is visible as UNKNOWN, can you check which ID’s are shown / reported back (in device settings)?

I could only see the node in z-wave network. On the device page i can’t see anything. Later today I can try to include all thermostats on more time, since i kinda gave up last night.

Resetting the Z-wave network is not needed per definition.

Did you try to include the thermostat at close proximity to Homey (move Homey to the thermostat)? See detailed instructions mentioned in: Heatit Z-wave app (v2.2.1, v2.3.0-BETA)

I am having the same error message @Andren .

Try shutting off power to the thermostat, remove any unknown node from https://developer.athom.com/tools/zwave , then power on and reset the device (hold center and right for 20 sec)

add new device from homey app, but do NOT choose heatit device, choose Homey -> Zwave device. this has yielded success for me.

however, devices are very unresponsive and unreliable unfortunately. Especially reporting floor tempereature is a problem, it does not do it. i have logs if anyone would like to see.

as you can see , some devices dont update at all. its been 4 days since install.

would love to contribute information to get past these diffiiculties

@Christer @Andren It is not mentioned explicitly; did you both install the BETA version (v2.3.0) of the app from the app store?

Based on the node overview of @Christer, I see all devices are added secure.
This could (likely) be caused by choosing the generic option Add device > Homey > Z-wave device… don’t use that generic option!!

I didn’t realize this before, but in this way, the inclusion will be done based on the generic Z-wave profile (= secure) where only in the last step the match towards the app and driver is being made.

Only by using the BETA version of the app, and choosing Add device > Heatit > Z-TRM2fx, the default profile is overruled and secure inclusion is blocked. And as mentioned, S2 secure inclusion is the cause of the stability issues in communication between the Z-TRM2fx and Homey.

@Christer can you remove all devices again and try using the Add device > Heatit > Z-TRM2fx option?

I will try to add it more explicitly in the FAQ / instructions referenced above.

thank you for the speedy reply! I am indeed not on beta, will upgrade an reinclude unsecure one or two devices to see.

the problem i overcame by adding the “generic zwave” way , was that the device would include again with its old device id , and would not confirm its pairing following that, just giving me “unknown node” over and over again. pairing via generic zwave made the process super speedy, with “incl” showing on the display almost instantyl whereas the other way most often would just give an “err” . so there is some difference here that gives some hints to parts of what could be wrong.

will check out the beta and give feedback. will try both ways of including and see the result.

Im using the beta version and have only tried to include Add device > Heatit > Z-TRM2fx. Now I tested on more time and I’m still getting the strange status “cannot restructure property wakes-interval of undefined or null”

I can see on the developer page that its added to the network as unknown.

I have now overcome this successfully. remove node after taking the power first. then add with generic zwave. then remove device, then add again with the ztrm2fx option. it will say “err” in display, followed by Inc

I got the exact same error on my first attemt by the way, "status.Cannot destructure propert ‘wakeupinterval’ of ‘undefined’ or ‘null’ . Removed the device, removed unknown node and reset the thermostat as descrbied above. I have tried one more thermostat today, which was an immediate success.

the one that gave me trobles was the one that had almost no communcation , tx/rx count . the one that was easy to exclude and reinclude had a high number. it also had “last working route” noted , while the other one was of the “unknown” kind. (im referring to my screenshot further up in this thread.)

I can also confirm that adding device as “generic zwave” did indeed include it secure.

I am now having trouble associating my thermostat with an external device, a fibaro single switch 2, which has a heater connected to it. could it be becuase one is now secure and the other is not? is there any way to include the fibaro switch insecure as well?

New post(limited to 3 posts so editing this one):

Very happy about the effort that has been put into this @TedTolboom , speaking as someone who tried learning programming and couldn’t :slight_smile: I’m also not experienced in online forum etiquette and I genuinely hope you will let me know if I step on some toes, that is not my intent.

About the thermostat, I’m still not recieving regular updates on the floor temperature.

Looks like the I am getting the following lines in The log for the node that had floor sensor:

2019-09-25T18:15:00.470Z
Node[66]: Decapsulated frame from COMMAND_CLASS_MULTI_CHANNEL to COMMAND_CLASS_SENSOR_MULTILEVEL, data 0x0501220000

Also:

Node[66]: Received application command for an unknown Command Class, data: 0x310501220000

If any of this is helpful i’d be glad to send over the entire log

Just giving a status about the including and re including of HeatIT ZTRM2FX.
As other users known they don’t reacted at all. I even had trouble removing them from my network.
As I started after installing the beta app I had to wait around 20 min for include them at all.
I got the same issue as @Andren mentioned in a earlier post.

I did the following steps:
Remove device from homey
Reset device / thermostat
Restart homey
Turn off power to the device / thermostat.
Turn power back on wait a little.
Try to include if this fails remove add device and do a new reset of device in worst case.

With the new version off the app I did regain control over these devices.
Until now it looks stable about a week.
I also recognized trouble with other devices by slow communication with homey, since I removed all heatit thermostat and re included with the beta version it seems my communication problems with other devices vanished.

Thanks @TedTolboom for releasing a new app for getting control back of the heating thermostat.
For your effort and time I donate to your app.

If help is needed just get in touch.

Best regards.

Easiest option would be to connect the thermostat with the switch via a Homey flow.
Otherwise, you will need to modify the Fibaro app manually (not preferred)

Just to check, which firmware are the Z-TRM2fx’s running on? The latest 3.6 (still showing during booting as 3.4)?

It’s just size 48…
Just keep in mind that I’m doing this in my spare time, without having a Z-TRM2fx device installed at home (only as development device).

Could you share the entire log (as attachment)?

Thanks for the feedback and contribution @Alex.Robins! Much appreciated!

1 Like

New Beta release will be available in the app store shortly (awaiting Athom’s approval), adding support for the Heatit Z-dim rotary dimmer

1 Like