Homey Community Forum

Heatit Z-wave app (v2.7.0)

Thanks a lot for a quick response. I can see floor temp now, but current, voltage and power is still not showing up for some reason.

Can you try to disconnect and reconnect power to the Z-TRM3 as additional step and report results?

Tried to power cycle twice. Unfortunately no change.

Exclusion and inclusion with very close proximity helped in my case.

Hi. I am having trouble connecting the 4 channel push button to homey. I have succeed connecting 8 channel button with no problem, but the 4 channel button will not connect correctly. It just connects as a random Z wave device. See image below. Any suggestions on what to do?

Thanx for any answer.

@Hakon_Vinge Could you share a screenshot of the ID’s mentioned in the Advanced settings of the basic Z-wave device?

Is this ok?

Yes, thanks.
Are you sure that it is a Heatit branded device you’re trying to add to Homey?

The manufacturer ID points towards FutureHome AS…

Thanks. This is a picture of the back of the device.

Then I would contact Heatit (I’ll make a report as well); apparently something went wrong with the firmware programming.

Thanks a lot. Just to clear out. I have tried four different items. They all give the same result.

Likely this is batch (FW programming) related. I’ve already send a message to my contacts at Heatit to inform them and point to your messages / pictures.

1 Like