Homey Community Forum

Heatit Z-wave app (v2.7.1)

Here it is;

Diagnostic ID: ff9430c3-52da-4076-8994-9c3fad75e48c

And the logs: https://1drv.ms/t/s!AgWBe2qMKu3TmiJGbkgXiLezPsFy?e=eYaml9

Hi there!

I just started with homey and I want to control my lights. I don’t now if this here is the right place but I have a question to the Z-DIN 616 device:

As in all our house the lights are regulated with low voltage momentary switches (“Taster”) I wanted to use the Z-DIN 616 to replace the impulse switches (“Stromstoßschalter”) in our haouse. In my test, it basically works (inclusion in homey, switching,…), however when I turn the light off via the app I have to click the physical switch twice to turn it on again. Is there a setting to solve this issue?

So this is what happens:

Press switch -> light on
Press switch -> light off
Press switch -> light on
turn off via homey -> light off
Press switch -> nothing happens (!)
Press switch -> light on

I tried to change the “function input” parameter to all available settings (“level controlled”, “falling-edge” or “rising-edge”) but this did not help.

Thank you for your help!

Hi @TedTolboom, did you find some time to take a look?

In the meantime I have moved my Homey to approx. 1m from the most central Z-wave device and I have had no problems ever since. Some of the Z-wave route’s are a bit weird, but if it works, fine by me.

However, the new location of my Homey prevents me from using the LED-ring for notifications and the sound for the doorbell. So, if you can find any other solutions, I’m still very much interested.

Hi, Im having huge problems including two TRM2fx. Both thermostats work, and both show the same problem : “err” when including (i tried about 20times with each thermostat with the homey about 20cm away. It looks like the homey starts inclusion and i get a new Device, it however does not finsih the inclusion. Reset og the TRM2fx does not help. At the end of the inclusion process it looks like the TRM2fx is reset and all saved settings are deleted (i.e. the sensor impendance) and its turned off.
The thermostat has worked untill some resent update, but with some update it became unreachable.
Thanks for any help.

Version 3.4 of the thermostat FW.

Reset everything, reinstalled the app and got it to work. :slight_smile:

Theres a new floor thermostat, HeatIt Z-TRM3. I have sent an inquiry of their availability and am considering ordering one as they become available. Z-TRM2FX is already marked as EOL (End of Life) by HeatIt. Anyone else know anything about this?

There’s also a mention of a wireless thermostat, the Z-Temp2 on the page of the Z-Water. Seems this is another new product about to hit the shelves.

What is required for these to be added to the list of supported devices and is there something I can help with?

1 Like

One of my TRM2fx recently stopped working, and got replaced with the new model z-trm3 today.
I hope support for this model will be added in the near future.

1 Like

When I talked to ThermoFloor two days ago they said they had sent documentation for Z-TRM3 to Homey, so they expected support to be added “soon”. Crossing fingers, as I just got two of them installed, and waiting for Homey integration.


But @TedTolboom would of course have the best information and estimate.

Well, I just received the shipment notification for my Z-TRM3 so I could start to add support for it in the app. Keep you updated.


I have several Z-TRM2fx devices for controlling floor heating in my home. I have issues getting Homey Heating Scheduler to set all the thermostats as scheduled. Sometimes it works and sometimes not.

I have done a lot of digging to find out why this was not working and I think I found the reason.

It seems that Homey very often believes that one or more of my Z-TRM2fx devices are unreachable. This in turn seem to mess up the z-wave routing resulting very bad / long routes.

I’m not sure how Homey handles communication with unreachable devices, but maybe it just skips sending the commands.

I think it is the Heatit z-wave driver that reports (or not reporting) the z-wave device statuses to Homey. I never had any issues controlling the thermostats from the device pane in the Homey app, so I suspect the devices are in fact communicating properly even if Homey believes they are not.

Node 2 – 8 are Z-TRM2fx devices. 9 and 10 are two different Fibaro devices. If I do a test on an unreachable device, it reports OK and the unreachable flag is removed. After a while the flag is set again. The Fibaro devices are never flagged as unreachable.

Can you please have a look into this?

I’ll be happy to provide you with more info if necessary.

Jan Olav

Homey is saying the same at my end, that they are unreachable. However I am not having any problems with flows what so ever. If I click heal it will tell me it is reachable but after a while it will change back to unreachable.

What’s the name of this z-wave debug tool?

Just type developer.athom.com and login with your homey account.

Now waiting for support of the HomeyApp :wink: (thanks for the great work again @TedTolboom)

@TedTolboom die you have an expectation when the app will be updated with the new Version?

I got an answer from Thermo-Floor. There is a new firmware to solve this bug.

Can anyone help me or link me to instructions how to make a OTA firmware update for the Heatit Z-DIN 616 device? Is it possible with homey? It’s a .otz file: https://box.hu-berlin.de/f/4b79c13a639e43ae9986/?dl=1


Mabye i doing something wrong or its something els but it can’t get the floor temp value of my Z-TRM2fx with floor sensor. And the temp of the divice is different then the one i see on the app can someone help me? I already exclude and include. And i double checkt if the wires are in the right spot.

sensor mode i changed to 0(floor) but no results it looks like it don’t pull the floor sensor value
The device dons’t give a ER4 so there is a sensor