Homey Community Forum

Heatit Z-wave app (v2.7.1)

Hello! I’ve tried to pair a Heatit Z-Push button-8 to a fibaro dimmer 2 directly. The devices pair as they should and I can use the buttons to control the fibaro on and off etc. But, when I’m holding down or up the button to dim the fibaro dimmer, it just continues to dim even after I release the button. I can just dim it to max or min, as it won’t stop when I realse the button. Is this a common issue?

I’ve just released the v2.7.0 update of the Heatit app adding support for the (long awaited) Z-Smoke AC Smoke Detector. The update is pending the app store approval of Athom, but can be installed already through: https://homey.app/a/no.thermofloor/test/

2 Likes

First thanks to @TedTolboom for the great app !

I installed Z-TRM3 yesterday and I had to do the same magic than @Naitsirk explained before (the association from 1.1 to 1 and back).

First I included the Z-TRM3 when Homey was about 10m away. I noticed that the power and energy measurements were not updating. Tried to do the the association trick, but the measurements still didn’t update.

I moved the Homey about 1m away from the Z-TRM3, exluded and included again, did the association trick and voila! the power and energy measurements started to work.

Just for the info that @Naitsirk is not alone with the “problem”

Hi

Got my 6 z-smoke detectors today. Easy to install, also very easy to include (thank you @TedTolboom). However, association was a bit tricky. Can not seem to get any associations, always get this message… I have 6 detectors, so I should be able to get each of them associated with the rest. But even if I just try one I get the same message.

Update, got 4 of them to work but the 2 left still gives me this message. Tried restarting the app, didn’t help.

Which Homey version are you using?

Hi. I’m on 4.2.0. Strange that 4 went ok and 2 didnt. Remove and add them again to see?

Did you find a solution for this ? I’m having the same problem when using association, relay status from z-water will not update in the app or in homey insight. Z-temp2 seems to work ok

@TedTolboom is there a fix for this? Is there something in the setup that I’ve done wrong ?

My z-trm3 stopped reporting power usage for about 2-3 weeks ago. I noticed it was reporting constant full power usage all the time, and it haven’t updated in about 2 weeks. Reboot of homey did not help. But when I changed language to English (to take screenshots) and rebooted it suddenly changed to reporting 0w, so I thought it started working again. But sadly not. Homey never receives any updates regarding to power usage. But temperature is reported as normal.
Should I exclude and include again, or can something else be wrong?
All my z-trm2fx works as normal.

See attached screenshots.

Ok, sorry. I just tested “the “1.1” association group override trick (set the value to 1 and then back to 1.1)”, as @Naitsirk wrote earlier, and that worked!

I did not fully understand what I just did, but it worked.

manged to fix it. Changed the settings in Group 1 from 1 to 1.1 in both devices… it seems to work now :slightly_smiling_face:

I believe the issue is related to the fact that the property values shown in the app are not read from the device, but based on the defined default values on the device. When you change a property value in the app, it will send it to the device and the app and device will be in sync for that property. If you change a property value on the device, the app and device will no longer be in sync for that property. When using the app, the idea is that you set all the values from the app, and not on the device. The “set to 1 and back again to 1.1” trick is then simple: The value “1.1” shown in the app is not the actual value on the device. Changing the value in the app forces the value on the device to be updated and in sync with the app.

Well… it is a bit more complicated issue…

The right settings are (actively) set to set the multiChannel association to group 1 (as 1.1) upon inclusion.

So it is not similar to the device settings, that show the expected values, but are not actively set.

Apparently this multiChannelAssociation isn’t properly set during inclusion.

Which Homey version are you using?

Yep, this is probably correct, but strange if the device suddenly changed this value by it self? And it looks like that have happened to many of us.
And I did receive some values, but not all of them.

But could anyone please give me an easy practical example of what you can use these association groups to achieve?
Is it to get the thermostat to talk to other devices as well as homey?

Good to hear.
I do suspect that setting the Z-water lifeline association group 1 to 1.1 did the trick.
For the new devices, multiChannel association has been implemented, not yet for the Z-water.

Those devices will need to be migrated to this new approach. Not only changing the association groups, but also updating the driver logic.

Let me know if you run into other issues with the Z-water

Please check my previous comment I made in parallel…

You could use a association group (2 of the Z-TRM3) to turn on a separate electrical or infrared heater connected to a Z-wave wall plug in combination with the floor heater.

I was wrong. I didn’t “suddenly stop working”. It has never worked. (I just checked insights)

1 Like

Aha, thank you. :slight_smile:

Hi,
we are having issues with Z-Term3. I dont see anyone else reported it, so I would like to do it.
We have tested it on more thermostats, still the same issue.
For example, we set the temperature to 20,5 degree but it is showing 21 on screen (set to show set temperature on screen)
I have tested this multiple times and sometimes it is correct, sometimes it is not. Same issue I see on another homey, so it behaves the same on different system with another thermostat.

Is anyone else having this issue? It is not rounding up the 0,5 degree, sometimes I set 20 degree in homey and it shows 20,5 on homey. I can not find pattern in it.

Thanks

Hi.

Do you have any idea here @TedTolboom?

I have been in touch with heat-it and they actually told me that they dont know. Nothing more. Very dissapointed and they asked me to ask Homey, but Homey probably doesnt know either. So I just have to ask you again I guess. The message says d.commands.MULTI_CHANNEL_ASSOCIATION_REMOVE. But I dont understand, they have the same version as the 4 other that works, so perosnally it seems like these 2 doesnt wotk as intended and its Heat-it that need to replace them. Agree?

For people having issues with the power and sensor reporting of the Z-TRM3.

I am currently investigating the issue together with Heatit and Athom.
This issue appears to be a communication issue between the controller (Homey) and the Z-TRM3 during inclusion where the multichannel association group setting is not effectuated. Please note that this part of the communication is handled by Homey’s Z-wave core and all input parameters are set correctly.

As containment, please follow the next steps to force multichannel association group setting after inclusion:

  1. Open the Z-TRM3 device settings > Advanced settings
  2. In Associations - Group 1, change 1.1 to 1 and press save
  3. After confirmation that the settings have been updated, in Associations - Group 1, change 1 again to 1.1 and press save

All power / sensor data should now be reported by the Z-TRM3.