Homey Community Forum

Heatit Z-wave app (v2.7.1)

Thanks a lot for a quick response. I can see floor temp now, but current, voltage and power is still not showing up for some reason.

Can you try to disconnect and reconnect power to the Z-TRM3 as additional step and report results?

Tried to power cycle twice. Unfortunately no change.

Exclusion and inclusion with very close proximity helped in my case.

Hi. I am having trouble connecting the 4 channel push button to homey. I have succeed connecting 8 channel button with no problem, but the 4 channel button will not connect correctly. It just connects as a random Z wave device. See image below. Any suggestions on what to do?

Thanx for any answer.

@Hakon_Vinge Could you share a screenshot of the ID’s mentioned in the Advanced settings of the basic Z-wave device?

Is this ok?

Yes, thanks.
Are you sure that it is a Heatit branded device you’re trying to add to Homey?

The manufacturer ID points towards FutureHome AS…

Thanks. This is a picture of the back of the device.

Then I would contact Heatit (I’ll make a report as well); apparently something went wrong with the firmware programming.

Thanks a lot. Just to clear out. I have tried four different items. They all give the same result.

Likely this is batch (FW programming) related. I’ve already send a message to my contacts at Heatit to inform them and point to your messages / pictures.

1 Like

Any updates on this Ted? Thanx.

I would recommend that you contact Heatit support (or the reseller) directly to get this resolved.

I have the the Heatit z-trm3, and have been using if togheter with homey for a few months. I started getting some issues with the heating switching from active to idle every few minutes, so I tried resetting the thermostat and reconnecting it to Homey. Now I have the issue that the Thermostat does not actully switch on when I increase the set temperature above the current temperature.

Example: Measure temperature is 22.0. I set thermostat to 23 using buttons on the heat-it, and it turns on fine. I reduce the temperature to 20 using ahtom and it turns off. But if I increase the temperature using Athom til 23 the displayed temperature on the thermostat changes (after a 10 second delay that was not there before), but the thermostat does not actually switch on. If I then go in and change the temperature using the buttons on the thermostat it switches on.

Any advice is much appreciated

1 Like

I added the z-trm3 a couple of monts agom but then it started working. I removed it from homey, and did a factory reset in the cintrol unit. And now, i cant add it again. From the inclusion-instructions it lokes more like im trying to remove it, and also the unit only shows “Err” when i try to add it.
What can i do?

Never mind, it seemed to work now

Hi, I have an issues with connecting a new Z-Push Button 8. After following the procedure it starts connecting, and following message appears: “No compatible Homey App has been found for this device. It has been added as a Basic Z-Wave device”. Installers manual is dated 01.10.2019 Verson 2019-B. Both Homey and Heatit device is brand new. Any suggestions?

Edit: I have tried to uninstall / install the app on Homey. Factory reset of the Heatit device did not help either.

Edit: I have found my device is having same issue as @Hakon_Vinge is having with his 4 channel push button. Screenshot below. From what I have understood the devic supports over the air (OTA) firmware upgrade. Anyone know if new firmware is available and how to initiate it? @TedTolboom, apprechiate if you can share how to proceed with this issue. Do I have to return the devices to the vendor?

Did someone else have the same issue as me. I heatmy floor 2 times a day but the counters doesnt update.

Image of the back side of my Z-Push Button
Skjermbilde2