Homey Community Forum

Heatit Z-wave app (v2.7.1)

Did you set the advanced associations correctly?
something with Group 1 on 1.1, (its mentioned in this topic somewhere)

Any update on this one? Struggling with the same problem. Having 3 Z-Push Buttons working (2 Button 8 and 1 Button 4), but 1 Button 8 not able to connect. Getting same message as you.

Looking at the back of the ones working and the one not, it seems to be two different batches /versions.

Same issue with the 8-button :smirk:

This is the backside of mine, seems similarly as the other here

And the info from Homey

(I can only upload one picture at the time)

This smart device outsmarted me :thinking:

Did one of you try to contact Heatit about this? Maybe they have a fix/solution. I’m curious about what they have to say.

I just did now. I will notify for any updates

Update: I will get this replaced as it has wrong manufacturer ID

1 Like

I have the same issue in A and AF mode, but works fine in F (floor) mode

Hi

I have issue with adding a device. I does not work

Hi.

I keep having issues with the power and external sensor not reporting/updating. So i am not able to control the temprature with Z-TRM3 thermostat. I’ve tried changing the group from 1.1 to 1 and back but with no luck.

What can I do now? :frowning:

Same problem here too.
No communication with the Z-TRM3.

Hi!

I’m new to both HeatIt and Homey, and I have a problem I haven’t been able to figure out.

I have two Z-TRM3 thermostats, and they both seem to be connected to Homey (have exxcluded and included them, and the “stats” show up in the app. The problem is that one of them revert back to one perticular goal temperature no matter what I do. Both when I change the temperature “manually” in the app or through a flow, the temperature changes back to the same temperature after a few seconds again and again (in this case to 27 degrees). The strange thing is that it’s impossible to change the temperature on the actual thermostat aswell. This worked before I connected it to Homey, but not anymore.

Will try to exclude and include the thermostat again, hoping this will rectify it, but I would appreciate any helpful suggestion along the way.

I have been testing and debugging the Z-TRM3 issues over the last days and found the cause of the issues. It turns out that Homey is unintentionally setting up both a normal and multiChannel association for group 1, while only a multiChannel association should be established.

I’ve just released the v2.7.1 version of the app that should prevent this from occurring with new thermostats being added AND that will migrate all previously included thermostats to the correct setting (without user intervention required).

This version has been submitted to the app store for approval, but can already be installed through:

@RobFlu, @SpideQ, @cricket, @OAN please check if this is resolving your issues

Can you be a bit more specific? Which device and what steps did you try to add it?

No luck for me
Tried reconnect Z-TRM3 and cut power

If this update does not resolve your issue, I would suspect other Z-wave mesh issues.

What is the distance between Homey and the thermostat? Are there any Z-wave mains powered (routing) devices in between?

Does this communication resume when moving Homey close® to the thermostat?

Factory reset of homey, and everything working nicley now…
I also had an Ring alarm system I disconnectet from the Ring alarm hub.
Thanks for the help