Homey Community Forum

Heatit Z-wave app (v2.7.1)

Hi @TedTolboom any news regarding Z-TRM2?

So i went and bought 2 of theese z wave plus today, anyway i wait eagerly and will happily donate to help.

I appreciate all the offers…
but I still need to complete the SDK2 rewrite on the “old” thermostat first… #inprogress

Once that has been completed (and available for testing), I’ll check with ThermoFloor and or Robbshop to get one of the TRM2’s to be able to implement support for these devices.

I try to avoid borrowing devices from other community members as much as possible… because it is still a “way out of control hobby” with other higher priorities (family and work).

Thanks for answering.

It seems i actually bought the old version TF-021(also Zwave +) from amazon and not the Z-TRM2 thats awaiting certification.

is there any special trick connecting the TF-021 to homey? i keep getting ERR on heatit and cant find device on homey.

To answer myself, a reset fixed it for me on the HEATIT tf021, then it took a few seconds to connect the units to homey.

Have anyone update to the 1.92 software? the cable for updating is around €70.

I have done the update to 1.92 But after that it wont be recognized by homey more than a genric zwave device. I think its becuse they use new id:s.

Ted, you are doing really great work! and take your time we arent dying over this! :smile:

@Peter_Johansson If you don’t share the new ID’s… I’ll will continue to relax :grinning:

1 Like

@TedTolboom Manufacture ID 411 Product Type ID 3 and Product ID 513
With the new firmware all three (floor, room, external room) sensors will be availble on zwave and also info on relay status.
I dont belive that you are relaxing for a second! :sunny:

Quick fix could be to manually update replace the Product Type ID and Product ID in the ThermoFloor app: https://github.com/TedTolboom/no.ThermoFloor/blob/master/app.json#L393
And install that version of the app through the command line interface.

That will give back control over the thermostat via Homey, but will not yet add the additional temperature values / relay state (already part of my old driver using a trick)…

@TedTolboom I did that but i think they change some more things… invalid_commandClass_COMMAND_CLASS_SENSOR_MULTILEVEL is what i get and a broken sign on the device when its added.

Is there anything i can collect from it so you can get more information for the future version?

HI @TedTolboom any news regarding Z-TRM2? I had to replace them to standard ones. I will really appreciate.

@Peter_Johansson thanks for the feedback. Although there is no formal 1.92 manual, I found this FW 1.92 implementation description.
Nice changes BTW.

But it does not explain why you get the invalid_commandClass_COMMAND_CLASS_SENSOR_MULTILEVEL error. In this description, it does mentioned the COMMAND_CLASS_SENSOR_MULTILEVEL being there at the main node.

But I do have the update cable. :wink: So the plan of attack will be:

  1. Get the SDK2 driver confirmed working for FW <1.92 (see next post).
  2. Create an updated driver for FW 1.92
  3. Add support for the Z-TRM2
  4. Add support for the other devices

No, did not get feedback from ThermoFloor yet.

And also no signs of new certified ThermoFloor / Heatit devices at the product section of the Z-wave alliance

Once I hear something, I’ll update you here.

1 Like

Just one more thing…

I’ve updated the driver to SDK2 and debugged it with my development-thermostat; all functions (mobile interface, reporting, flow cards) appear to be working.
Some minor changes need to be implemented; but I wonder who will be able to find them :stuck_out_tongue_winking_eye:

So who would be able and willing to support in testing the SD2 version of the app and specifically the ability to upgrade from SDK1 (impact on existing flows)?
ie by downloading the SDK2 version of the app from Github and installing it (over the existing app store version) through the CLI.

If you contact me on Slack, I’ll add you to an (old) ThermoFloor private channel for sharing and discussing results.

I’ve tested, debugged and cleaned up the SDK2 rewrite of the Multireg / Heatit Z-Wave thermostat.
Including tests for the migration from v1.0.0 to v2.0.0 and clean installs…

v2.0.0 of the app is ready and awaiting app store approval.
Updating from v1.0.0 to v2.0.0 should go without noticeable issues.

Once v2.0.0 has been released and no major issues pop-up, I will update my development thermostat to FW 1.9.2 and create a separate driver for that version.

version 2.0.0 is available in the app store

@yermek That is step 1: the Z-TRM2 has passed certification

and I’m enjoying that I spend a bit more time to setup a “generic” Z-wave thermostat driver…
after adding support for the ThermoFloor Heat-it Z-wave thermostat (and finalizing v2.0.0), I added support for the MCO Home MH7(H) thermostats, within 2 days…


@TedTolboom amazing news! made my day :slight_smile: does it mean we need to wait a little bit? :slight_smile:

@Yermek Well that depends on how fast I can get my hands on an updated Z-TRM2fx.
I’ll check with ThermoFloor as well as Robbshop.nl.

In the meantime, I’ll be adding

  1. Trigger and condition cards for the Z-wave Thermostat
  2. Support for the Z-wave Thermostat (FW 1.92), which from functionality point of view, is again a step into the direction of the Z-TRM2fx (adding individual thermostat reports for the three sensors, but still missing the power meter functionality)
1 Like

Any feedback on the v2.0.0 app / driver update? Nobody left in the cold?

In the meantime, I’m finalizing an intermediate update (v2.0.1) that will add the flow card triggers and conditions for the thermofloor_onoff (relay state).

Hi @TedTolboom! Looks like some card don’t work(?), since none of my thermostats are switching over to Energy mode (or comfort) when I activate my Home Mode or Away mode. This worked perfectly before. Will have a close look at it this evening, but I’m quite sure it’s something strange with the thermostats since all of my other devices are acting as expected when I activate the same scenes. Anyhow, really appreciate all the work you put in!