Homey Community Forum

Heimdall - Let Homey watch over your home

How about this for a z-wave keypad: https://shop.domo-supply.com/en/security/1514-isurpass-z-wave-rfid-code-keyboard.html

and Joeri, here’s a collection of sirens: https://www.vesternet.com/collections/z-wave-sirens

Phil

1 Like

I’m not sure this is the right thread for it, but i’m happy with Vision Battery Siren. It has a buildin function to auto stop after 30, 60, 120 seconds of no automatic stop.

@HexaDroid
When not using a dedicated Siren device you can create flows like these to accomplish what you want:

Replace the Led Ring card with the Soundboard card to play your desired sound and adjust the delay on the Start Repeating Siren Flow after to the length of your sound. In the else part you could add a card to stop playing the sound (If that’s supported by the Soundboard app)

@Phil_Shotton
The Keypad for which I’m writing support is cheaper and has more functionality. It supports 2 way communication so it can show the current Surveillance Mode amongst others.

1 Like

Sounds interesting, @DaneedeKruyff!
Does it have a rfid reader as well, like the one @Phil_Shotton suggests?

I know that would be a further enhancement (a codelock alone would already be great), but it would be another nice-to-have… :slight_smile:

Thank you Daneede. Didn’t know yet you could trigger the flow again from within the same flow! Very handy!

Oh and can you already disclose which keypad will be supported? Might aswell already order one :slight_smile:

Sure, I’m working on an app for the devices from the Ring Alarm range of products. The Ring Keypad V1 is fully functional in combination with Heimdall. Unfortunately all other devices require Z-Wave Security 2 (S2) which Homey does not yet suppport.
See Ring Security - Extend Heimdall with Ring Security products

Ah cool. They seem out of stock though. Would be a shame if they stopped making the V1’s… :frowning:

Edit: Found some on amazon. :slight_smile:

For now I had an idea to create a google routine, where you have to say a random word to it, and it would trigger the disable alarm flow.

Just wanted to share a solution I stumbled upon for an issue I had in my specific use case, which is a risk of someone gaining access to surveillance mode from a wallmount tablet I have as a Homey dashboard.

A specific dummy user needs to be created for the wallmount tablet with a “guest” role. This will enable controlling your smart devices from the tablet, but restrict any management functions for devices, flows etc. This would still leave an option for surveillance mode to be changed to “disarmed” from the tablet at any time, so you would need this user to be disabled when surveillance mode is “armed” or “partially armed”. There is a dedicated card to do this from the flow, so I just added 2 flows which track surveillance mode status and switch the dedicated user created for the tablet to “enabled” or “disabled” state accordingly. This way, after surveillance is enabled, you may only disable it from one of the regular users’ devices (family members phones in my case).

I find this solution better than customizing a dashboard for the tablet (so that surveillance switch is not there at all), as this also allows to have a regular Homey mobile app to remain installed on the tablet just in case - disabling the logged in user restricts also any actions via the app.

Wondered when the User Management functionality introduced in the recent update would be of any use?
Well, the Ring Security app is now available for testing! It’s still labelled beta because it may contain errors but rest assured that it’s already been thoroughly tested in the private alpha testphase so I don’t expect any breaking bugs to surface. Another reason for the beta label is the fact that it’s not yet (completely) translated, but it will be soon.

Read more about it here: Ring Security - Extend Heimdall with Ring Security products

I have setup Heimdall according to the instructions without any delays, but I do not get the alarm triggered. When the status is ‘armed’ and a sensor detects motion it does not trigger the alarm. In the log I read: “Hal upstairs: Motion detected, no alarm trigger due to running countdown”. Anything I might be missing? Thanks for the reply.

Hello Mike,

Can you please post a screenshot of the Devices - Settings page and of the DELAYS part of the Settings page?

Thanks for your quick reply Danee. Please find the requested screenshots below:


You’re welcome.
From your screenshots I see nothing that’s not Ok, and I’ve also looked through the Diagnostics Report you sent but can’t find anything their either.
So, it’s hard to determine what’s going on, but let’s try to fix it.

Can you please set an Alarm Delay of 30 seconds and select Delay on the Hal Upstairs sensor?
Next, make sure Hal Upstairs is not detecting motion and set the Surveillance Mode to either Armed or Partially Armed. Next, Do a little dance in front of the sensor, wait a couple of seconds and set the Surveillance Mode to Disarmed.
Please go into Heimdalls settings and send a new Diagnostics Report.
To disable the Alarm Delay you just have to remove Delay from Hal Upstairs, there is no need to set the Alarm Delay value to 0.
You can then do the test sequence again, see what happens and send me a new Diagnostics Report.

Can you please add the time you started the tests in the remarks in the Diagnostics Report, that will make it a lot easier for me to find the part of the report that is relevant.

@Mike_de_Mots Thanks for the logs, I’ve looked at them and see it isn’t resolved yet. Somehow the variable alarmCounterRunning is set and doesn’t get unset.
There’s some things to try.
First, remove any Delay from your devices, next (I’m not sure if it helps but better safe than sorry) make sure the Arming Delay and Alarm Delay are not 0)

Things to try, any of these steps should reset the variable:

  • Enable the Allow Alarm while in Alarm Delay and do the test again.
  • Stop and Start the Heimdall app, this should initialise the variable and set it to false.

If that doesn’t help a reboot of your Homey should also reset the variable.

Please let me know if this solves this for you.

I was reading through this whole post and noticed this unwanted low battery behaviour of the neo coolcam devices. I fully agree that you want/need sensors that handle low battery situations gracefully. False alarms are to be avoided.

Is this still happening (low battery causing false alarms) with neo coolcam sensors?

Interestingly @DaneedeKruyff is working on support for Ring devices (motion and contact sensors) (see this post) that seem to be very reasonably priced considering they are official zwave devices. One would expect that ring/amazon should be capable of implementing the specs correctly on their sensors.

cheers
Onno

This is something I don’t experience with my Neo Coolcam PIRs v2 and v3. I did had the battery problem with Fibaro PIR, Maybe a version difference, but for me the CoolCam PIR’s work very well.

I would like to reduce number of possible false alarms (i.e. triggered by motion sensor due to sun reflections or mosquito…)

Is it possible to require that at least two sensors (preferably within a security/perimeter group, i.e. kitchen, leaving room) need to get trigger within x seconds before the alarm siren is triggered and push notifications is being sent?

An example, in the leaving room I have to motion sensors, very unlikely that both will create a false motion trigger at the same time or within 60seconds, but very likely that they will create a real motion trigger when someone is walking in the room within 60seconds.

Hi Welcome on the forum and thanks for using Heimdall

Heimdall will always activate the Alarm State when a selected sensor is tripped in an active Surveillance Mode, no way around that.
That said, you could choose to not use the The alarm is activated card but the Sensor tripped in Alarmstate card to trigger the flow to take action on an Alarm. You’ll end up having to deal with some other stuff, like should you disable Heimdalls Alarm State when your false positive is no longer active? Do you only want this for this particular sensor that gives the false positives? Etc. Etc.
So, I think you’re better of fixing your problem at the root cause, a sensor giving false positives. Either repositioning/re-adjusting the sensor, not using it in Heimdall, dynamically removing it from a Surveillance Mode with the Add/Remove sensor from Surveillance Mode action cards on sunny days.
And I realize it will take a (lot) of time to read this whole thread but I’m sure you’ll find it usefull as a lot of tips and tricks can be found on how to fit Heimdall to your needs.

False positives can be a pain to eliminate completely.
So, I got this idea:
Create a virtual motion sensor, which is set to motion alarm=true, if f.i. both the hallway and livingroom sensors motion alarm=true.
Replace the hallway and livingroom sensors with the new virtual sensor in Heimdall.

I assume your sensors hold the motion alarm state for 1 minute.
This can be done using the ‘a zone becomes active’ trigger, and then the order in which the sensors went into motion alarm is important, and configurable; The first active sensor is in the AND part with the ‘a zone is active’ card, the second active sensor is the trigger.

Otherwise it can be done using ‘an alarm became active, and the sensor is
Motion’ trigger, with both zones as a condition.
Now the order of the sensors going into motion alarm state, is irrelevant.

I would strongly advice to not overcomplicate your setup, just to get around a sensor giving false positives.
Ask yourself what you want to happen on a overcast day or during nighttime. Do you need that sensor to trigger an alarm by itself? Yes → fix the false positives. No → You don’t need that sensor anyway so don’t configure it in Heimdall
Don’t try to mitigate a symptom, fix the problem.