Homey Community Forum

Heimdall - Let Homey watch over your home



White alarm button is default for Homey v2. If an alarm is active, an additional icon is shown. Press and hold to check more details of the alarm and store detail screen to the right for a button to cancel the alarm.


Thanks @jc82517

Are you using the Set Surveillance Mode action card from the Surveillance Mode Switch?

When that card is used a Arming Delay will be stopped when setting it to Disarmed.


Hello @J_Pouwels,

The Alarm Off Button is to disable the Alarm State not to (partially) Arm the system, you need to use the Surveillance Mode Switch for that as per instructions in the opening post.



That’s fixed in 2.0.4 which awaits approval by Athom.


New version published

Version 2.0.4

  • Prevent creation of default flow cards for Surveillance Mode Switch
  • Added examples to flowcard tags
  • Code cleanup

Homey V2 automatically created flow cards based on only a capability, This resulted in creation of trigger-, condition- and action cards on the Surveillance Mode device which were unwanted. This version prevents these cards from being created but also removes cards that were created before so please check your flows for missing cards!


Couple of questions;

  1. The device has not reported in 24 hours, is there a way to keep it from spamming the logs?

  2. I cannot find the clear logs button anymore?

  3. Why am i seeing these two events and what is the difference? It happens when i leave the geofence;

**11:25:56.186 **



Surveillance mode is armed.

And then 5 minutes later;

**11:29:15.223 **


Surveillance Mode Switch

Surveillance mode is armed.

Same on entering, I see two events. Dont think ive seen this behavior in 1.5


Hi @Hannes85,

Devices that have not communicated in the last 24 hours will always be reported to the History View on the Dashboard, the only way to keep them from creating a line would be to make them communicate.

The Clear History button is currently hidden, when starting the rewrite for Homey 2.0 I hide that button and also the Download button. Now that most technical issues are solved I will look into improving the UI/UX and bringing it back. In the mean time, you don’t have to worry about the History filling up your Homey however, Heimdall will make sure it doesn’t grow to larger than 2000 lines.

I can’t really tell why you see 2 events when leaving the geofence. The first is from a flow card so I suppose it’s a flow you made that is triggered by someone leaving, the second appears to be from using the Surveillance Mode switch.
Do you have an Arming Delay configured?
Can you send a Diagnostic Report and inform me when this happens again?


Thanks danee for the detailed reply, this truly helps in Understanding.

Ive sent you the diagnostics per Pm. I have no delayed arming. Maybe the homeykit app does something quirky? Because I have a surveillance mode switch there? Not that I touched it but a refresh (on opening HomeKit on the phone) in homekit could be the only thing causing this i think…

Keep up the amazing work!


i cant clear the log 2.0.4 of heimdall on my android phone in v2 , i dont see the clear buttun which was available on homey v1 settings ? in the nox player idont see the log at all


You only have to Look Up two posts to get your answer…


New version published

Version 2.0.5

  • Improved settings user interface
  • Code cleanup

Made a start with improving the settings user interface, made it a bit cleaner and more consistent in style. Also removed some old V1 code.


It still doesn’t work with the Aqara Motion Sensor. Got a new batch today and it detects motion, Heimdall gives the proper message that the motion sensor triggered Alarm. And Alarm is activated in the log. But no push notification to phone and/or no sound of siren (Neo Coolcam). But if any other motion sensor (Aeotec MultiSensor or Aqara Window/Door Sensor) is triggered, the push works and the siren starts making sound.

It’s extremely weird. I’ve made a Diagnostic Report and I will send the code to you via PM.


Settings is looking a lot better! :slight_smile:
Page width is consistent everywhere now, but I still have to ‘pinch’ the screen a little to zoom out because a part is missing on the right otherwise


Hi @SpaceCosmos,

I’m looking into the log, but it doesn’t seem to make sense.
At enumerating the devices it does find the Aqara devices, but it seems there are no Surveillance Modes selected for the Aqara Motion Sensor.

2019-01-30 20:13:14 [log] [Heimdall] Found contact sensor:       Aqara Window/Door Sensor
2019-01-30 20:13:14 [log] [Heimdall] Attached Eventlistener to:  Aqara Window/Door Sensor: contact, Fully Monitored, Partially Monitored
2019-01-30 20:13:14 [log] [Heimdall] Found motion sensor:        Aqara Motion Sensor
2019-01-30 20:13:14 [log] [Heimdall] Attached Eventlistener to:  Aqara Motion Sensor: motion

A bit further the Aqara Motion sensor is triggered and it still shows no selected Surveillance Modes to be included in.

2019-01-30 20:17:56 [log] [Heimdall] stateChange:                Aqara Motion Sensor
2019-01-30 20:17:56 [log] [Heimdall] sourceDeviceFull:           false
2019-01-30 20:17:56 [log] [Heimdall] sourceDevicePartial:        false
2019-01-30 20:17:56 [log] [Heimdall] sourceDeviceLog:            false

A bit later after the Surveillance Mode is set to armed the sensor is triggered again and it does a full correct routine but now it does show selected Surveillance Modes. This doen’t make sense to me, unless you changed settings on that sensor in the mean time.

2019-01-30 20:20:27 [log] [Heimdall] stateChange:                Aqara Motion Sensor
2019-01-30 20:20:27 [log] [Heimdall] sourceDeviceFull:           true
2019-01-30 20:20:27 [log] [Heimdall] sourceDevicePartial:        true
2019-01-30 20:20:27 [log] [Heimdall] sourceDeviceLog:            false
2019-01-30 20:20:27 [log] [Heimdall] Full||Partial||Log:         Yes
2019-01-30 20:20:27 [log] [Heimdall] sensorStateReadable:        Motion detected
2019-01-30 20:20:27 [log] [Heimdall] Alarm is triggered:         Yes
2019-01-30 20:20:27 [log] [Heimdall] Trigger is delayed:         No
2019-01-30 20:20:27 [log] [Heimdall] logArmedOnly:               false, Surveillance Mode: armed
2019-01-30 20:20:27 [log] [Heimdall] logTrueOnly:                false, Sensorstate: true
2019-01-30 20:20:27 [log] [Heimdall] Say:                    The alarm is activated
2019-01-30 20:20:28 [log] [Heimdall] sModeDevice alarm_heimdall: activated

The triggering of the flow card does not write a logline when succesfull but would if it would fail so I have to assume the card is triggered.

I have some additional questions:
Did you change settings on the sensor after stopping and starting Heimdall?
Does the Aqara Motion sensor show up correctly in the developer tools?
Did the Aqara Motion sensor add in 1 try or did you have troubles adding it?
Have you rebooted your Homey (by unplugging the power) after adding the sensor?
Was a line written to the History on the Dashboard tab in the apps settings?
Can you post a screenshot of your alarm flow?
Do you know how to install an app using the CLI?


Thanks @Fire69

Can you post a screenshot of a page where this happens (before adjusting the zoom)?
What kind of phone are you using and do you know its resolution?


Is it possible ta ad a button or change the original button that i can see in witch static it is? Maybe in colors? That will be fine than I never have to open the app to see his status.


Hello again,

Sorry, I could be mixing up as when I added the device and when I generated the Diagnostic Report. But I made a new one now and sent it to you via PM, together with screenshots of the Flow triggering push and sound of siren and the Dashboard.

As for your additional questions, I’ll try to answer them in short here:
Did you change settings on the sensor after stopping and starting Heimdall ?
– I might have?
Does the Aqara Motion sensor show up correctly in the developer tools?
– Yes.
Did the Aqara Motion sensor add in 1 try or did you have troubles adding it?
– Yes. Paired and worked at once.
Have you rebooted your Homey (by unplugging the power) after adding the sensor?
– No, not with this new sensor, but have with the previous one.
Was a line written to the History on the Dashboard tab in the apps settings?
– Yes. (See screenshot sent via PM.)
Can you post a screenshot of your alarm flow?
– Yes. (See screenshot sent via PM.)
Do you know how to install an app using the CLI?
– No, not with version 2,0 of Homey.

Hope this helps!


Just looked a bit better at it.
Everything is shown correctly within the screen except the ‘Instructions’ tab-label at the top.
And because of that you can scroll horizontally a little.

Resolution is 1440*2560 (Galaxy S7)


This MIGHT be way off but since it does sound oddly familiar to behavior that I have been seeing I will share it nonetheless;

I am running into a known problem (resolved in homey 2.0.2 RC2) where a WHEN card with “state changed” is not seen by homey (not for every device, it is extremely random). Didn’t bother requesting the details but on slack the answer was very clear;

Again, I don’t know the exact details but the behavior feels familiar to what I have been seeing. Haven’t tried updating as I don’t want to go to the experimental channel but feel free to try it yourself and let us know the results? :slight_smile: