Homey Community Forum

Heimdall - Let Homey watch over your home

@Rindler I have just checked but I can’t reproduce.
Does this happen for all devices?
Can you disable and re-enable the Only when a Surveillance Mode is active setting and check again?

@Henk_Renting you are right, it’s not really clear like this, I’ve changed it and it will be available in the next release.

1 Like

Now I feel stupid. Maybe it’s been like this all the time. Obviously the devices which are logged are the ones that have the setting “log”. They are not active in Armed or partially armed. I thought when I have selected to just log when the surveillance mode is active that those sensors would write to Heimdall dashboard, and not cause the alarm, but when the surveillance mode is disarmed that they wouldn’t be logged…

Great support @DaneedeKruyff! Thanks.
Keep up the good work!

@rindler Devices that have the setting Log will always log regardless of the Only when a Surveillance Mode is active setting(*). This setting is meant to prevent logging from devices with the Partial and Full setting when no Surveillance Mode is active.

(*) With the flow cards introduced in version 2.0.22 and 2.0.23 you can dynamically set the Log setting based on the Surveillance Mode like this:

@Henk_Renting Thanks!

2 Likes

Thanks for your help and explanation!

1 Like

Hello Danee,

I’m searching for a possibility to check the online state of my ABUS smoke sensors - to see if they are still connected to Homey or the zwave mesh.
I can’t see the time last seen in the development view (Z-Wave) or in the device itself. So I hoped to see the state in your app.
Perhaps this would be a reason to add smoke sensors?
-> see the state like time last seen, only in the devices/state page, not in the settings page (for alerts). I confirm, alers should be independent of arming with Heimdall.
-> check the last seen time with timeline comment like it is possible for motion sensors in the settings page.

So far my ideas…but perhaps you have another idea or app I haven’t ween yet where I can check the sensor state?

Thank you
Ronny

Hi @RonnyW

You can see the last update from your sensors on the devices developer page where it is shown like this:


I have no plans to add this to Heimdall

Hello Danee.

Have one question/problem:
(Surveillance mode - SM)

When I change SM in the Homey to Armed then SM in the Homekit also changed for Armed - Everything fine and correct. But when I change Homey SM to the Disarmed, then SM in the Homekit changed to disable, and if I change Homey SM to Partially Armed, then SM in the Homekit changed to Home.

Ill use. Heimdall - ver 2.0,35 and HomeKit Sprut 3.1.0
Maybe you have any solution, or maybe im do something wrong?

Thank for your assistance and your time.

This is exactly what one expects. SM disarmed is OFF. partially armed is Home in HomeKit because the alarm is enabled but only for certain zones because you are still at home and do not want to trigger the alarm when walking around in certain zones (bedroom, bathroom for example).

Yes, I can understand this, but the question is whether it is possible to configure Homey and HomeKit to coincide.

It does coincide, the used terms are just different.

Hello @Gennady

Welcome to the community, thanks for using Heimdall. Homey and Homekit both use their own names describing the Surveillance Modes as explained above, I have no influence on the actual names. If your concern is the mapping between the different modes (last time I looked Homekit used 4 modes and Homey 3) you will have to contact the developer of the Homekit app.

1 Like

Hi guys

Have been using Heimdall for some days to play around with but now I’m ready to give it the well-known Wife-Test and implement it in our daily routine.

But now suddenly nothing happens when clicking the ‘Surveillance’ device on my app. I don’t think I have changed anything in my config though.

Is this something I have caused - any ideas of how to solve it?

-Kenneth

A simple click just deactivates the alarm.
Make a long click and change the mode in the device mode view.

I feel like a jerk now. Haha. Simply forgot to press-and-hold. Thanks, Ronny.

1 Like