Homey Community Forum

Heimdall - Let Homey watch over your home



I have also started using this great app since today.

I have come a long way, I have the flows. I programmed it so that the alarm system is activated / deactivated using NFC tags. this works well.

only now my question: I have put in as soon as the alarm is on and the door nevertheless opens a loud noise. is it possible that when the alarm goes off (the sound) I can switch it off remotely? I have the alarm button and I can turn off the alarm with that only deactivated that is not my sound which is in the activation flow state



  • Today I updated Homey to rc.7. I also created a new flow saying: if ‘Het alarm is geactiveerd’ then ‘stuur een puchbericht’ and ‘Knipper de lamp (lang)’. Tested but still not working. I believe it is related to v2.0.0-rc.7 as I still experience problems with some other flows (even after creating a new flow).
  • I understand and I like this function. Well done!


Sneak preview


Logging “not for deactivating sensors”… oenga?


looks cool @DaneedeKruyff !


I have uppgraded the Homey to v2.0 and installed Heimdall v2.0. I used it on v1.5 and it worked great.

But now when i tries to configure it, the devices page is empty.



Heimdall is not ready for homey 2.0!
it is work in progress so it is normal that you don’t have a working settingspage.


Thats ok. It just looked that it work for the ones here that have tried it and i just want to say that it doesn´t work for me. :slight_smile:




IT LOOKS LIKE iOS!!! :wink:

(actually, it’s looking pretty cool, did you write styles.css yourself?)



Thanks! Yeah mostly, except for the on/off switch.


Sneak preview


Lekker bezig!


The ‘alarm is geactiveerd’ trigger is also not working for me. Currently, I have a temporary workaround by using the default devices card and trigger if any alarm was registered. In the condition I check for delay and the right zones, depending on partial/full surveillance mode.

I noticed my homey is saying ‘A30’ when enabling the surveillance mode with delay enabled?
I’m still running your version from Dec 16th on rc.9.

@DaneedeKruyff, if you have another version that is ready enough for testing, I’m happy to install.


I’m having a strange error with Heimdall (original version and the testign version for V2)
When Surveillance station is change to Activated, my 2 KaKu Aled2709 go On.
Ther is no Flow for it,. Very strange issue?

Yesterday I installed the V2 app and tonight my Fibaro Smoke detector went on 2 times.
I don’t know if it has something to do with Heildall, but it’s strange.

For now I delete the app, en will test it again when it’s stable.


I have done all this but i cant get the system to trigger the alarm and send push message.
When i do a test of the flow everything works fine.
When checking Heimdall`s log i get “motion detected, no alarm trigger due to running delay countdown”. I have tryed with no delay and with 15 seconds. No difference. Any suggestions?


Hi Guys, something weird, my 7 neocoolcam doorsensors stopped talking to heimdal on december 23th. Heimdal reports all of them as “Keukendeur in Keuken heeft al 24 uren geen info gestuurd. Laatste info: 2018-12-24 11:01:00”

Initially I thought of zwave issues (all devices refused to ack in the developper portal and I don’t in all honesty fully understand that ‘new’ interface) so looked at replacing the battery but these all seem fine. While troubleshooting with a simple trigger rule (if contact alarm gaat aan, then turn on the light) the sensors appeared to be working as expected and homey responding properly to the sensor. Heimdal does not report the activity in it’s log though.

Heimdal does properly respond and log activity on my hue motion sensors and trigger rules accordingly.

powering off Homey did not change the behaviour. running Homey 1.5.13 and heimdal 1.0.25. note that heimdal and the sensors were working as expected two days ago, no changes to settings or rules since. I noticed neo coolcam was updated 3 days ago, which is a clear suspect, but why would it still work in homey?

Any suggestions?


@molensky rc9 introduced a bug, it’s confirmed to be fixed in rc10:

For new versions, just keep an eye out on the alpha-V2 branche on github. I’ve been publishing small updates while not upping the version number, please check the duration since the last commit.


I can see no connection between the things you experience and what Heimdall does, it only listens to certain capabilities of devices and the only actions it takes are through it’s flowcards.


It somehow seems that Heimdall thinks a delayed countdown to an alarm is active. could you enable a Delayed Trigger on a device, select the Surveillance Mode on which that device should trigger, trip the sensor and let the timer run out (maybe enable some speech options so you can hear what’s happening). It should trigger the alarm and should reset the delayed countdown variable. After that set the Surveillance Mode to Disarmed and disable the Delayed Trigger on the device and see if all is functioning as desired.
Please let me know if the above helps.