Homey Community Forum

Homey Backup and Restore - Homey Migration

Got Homey backup installed on my new Homey Pro.
However, all Zigbee related is not working. Still searching.
Also in the Add devices page, I cannot click on a device to Re-enter a device.
these icons also keep rotating.
Any help?
All flows, apps, z-wave, settings etc are installed correctly.

Have you Checked https://developer.athom.com/tools/zigbee .? Are all devices there like before?
Always give Homey ~ 15 minutes after reboot to start Zigbee, if it doesn’t work then PtP for a couple of minutes and try again.

Same after PTP, waiting 5 mins, plug in again and reboot wait 25 mins.
Same screen in developer.
Looks like zigbee is not activated? No system information…

@Minimax

Upgraded from Homey to Homey Pro yesterday when 4.0.0 stable came out. I have to say, it was a pretty good process. All of my Fibaro and NEO Coolcam Z-wave devices where migrated, also for Shelly devices no problems. For Zigbee, my Heiman and most of my Aqara devices migrated. Some of my Aqara sensors did not seem to react anymore, but after un/replugging an IKEA plug (that was acting as a repeater earlier) that also was not responding, the mesh got restored (I guess) and most of them reconnected. I only had to exclude/include two devices: one Aqara motion sensor, and one Aqara Temperature sensor.

All in all I am very happy to have been able to upgrade this “seamless”

4 Likes

Hi Dijker,
Tried to roll back yesterday several times, did not work all zigbee give same error (circle keep on turning.) Rest is working.
I m afraid I’ll have to do clean install.
Tried to install different backups, but no luck… The wife is getting a bit nervous since we can only turn on certain things with app only… :grin:

Hi, same here, going from Homey to Homey Pro. Everything works fine, except all my IKEA Trådfri, zigbee devices. They show up on the developer ZigBee page, but when trying to control a device, an error message is shown in the app after a few seconds. Tried power cycling the devices and Homey, but no luck.

1 Like

Can you try to add a already added device again, without removing it.
I guess when you get the duplicate device error it will start working again maybe even the other devices… fe a IKEA tradfri socket or repeater is the easiest as it has a reset hole.

It should not be necessary to fix flows that way.

Thanks, it worked again when adding the already existing device.

Just upgraded to homey Pro. Have to say that the recovery went extremely smooth for all my devices and all apps except for 1; IFTTT loses the flow connections and you need to rename the flows and applets in homey to connect again (same names do not update)

Well done on this one Athom, works like a charm!!

3 Likes

So they can actually complement each other?

1 Like

Yes, they can complement each other. I migrated a week ago and it was a smooth process. I had to pair a few items again, re-connect Google assistant, but all in all I am impressed. Good job Athom! Now Athom: please move ASAP on to the ZigBee rewrite!!!

1 Like

Did you have to do some special things to get Google working again? Reconnecting Homey to the google account does seem to work, but Google doesn’t deem to find Homey anymore. I just get the response from Google: Homey doesn’t react, try again later…
Already tried:

  • Disconnect Homey from Google home account
  • Rebooted Google home devices
  • Rebooted Homey
  • Connected Google home again

Same result

Any idea?

Have you find the fix please ? I’m currently facing the same…
I found workaround - Anyway, after searching a little, it’s necessary to go to https://assistant.google.com/services/a/uid/000000540d2e807f?hl=ent and press RESET (left bottom). After another Homey to Google re-link, it’s working.obrazek

In my case it was resolved after another software update from Homey. After that, i only had to reboot all Google homes (and mini’s). I did not disconnect and reset my Google home’s.

I will upgrade to Homey pro from a normal Homey

I have Xiaomi Aqara, zigbee device (Aqara) Yeelights neo coolcam Tuya fibaro apps and flows ?

Will all of this devices work with a backup/restore ?

Any of you have experience with upgrade to homey pro ?

10 posts up…

1 Like

Hello All.

I was migrating from one Homey Pro to another Homey Pro. I did a backup of the ole one and disconnected it. I connected the new one and went through the setup and restore process. All went fine but when the new Homey appeared online again some devices were missing. I noticed this from the flows and the list of devices in the HomeyApp on my Iphone. When I click on a device, it tells me unknown device.

any clue as to why this could be happening and how to solve it?

That can have 3 possibilities.

  1. app removed from the appstore so can’t re-install it during restore (you’ve got bad luck, if you’re lucky you can find a source code so you can install it via CLI)
  2. app installed via CLI (you need to manually re-install this)
  3. app installed via community appstore, this is pretty much the same as installing it via CLI for now (you need to manually re-install it again)
1 Like