Homey Community Forum

Homey Backup and Restore - Homey Migration

Yes, they can complement each other. I migrated a week ago and it was a smooth process. I had to pair a few items again, re-connect Google assistant, but all in all I am impressed. Good job Athom! Now Athom: please move ASAP on to the ZigBee rewrite!!!

1 Like

Did you have to do some special things to get Google working again? Reconnecting Homey to the google account does seem to work, but Google doesn’t deem to find Homey anymore. I just get the response from Google: Homey doesn’t react, try again later…
Already tried:

  • Disconnect Homey from Google home account
  • Rebooted Google home devices
  • Rebooted Homey
  • Connected Google home again

Same result

Any idea?

Have you find the fix please ? I’m currently facing the same…
I found workaround - Anyway, after searching a little, it’s necessary to go to https://assistant.google.com/services/a/uid/000000540d2e807f?hl=ent and press RESET (left bottom). After another Homey to Google re-link, it’s working.obrazek

In my case it was resolved after another software update from Homey. After that, i only had to reboot all Google homes (and mini’s). I did not disconnect and reset my Google home’s.

I will upgrade to Homey pro from a normal Homey

I have Xiaomi Aqara, zigbee device (Aqara) Yeelights neo coolcam Tuya fibaro apps and flows ?

Will all of this devices work with a backup/restore ?

Any of you have experience with upgrade to homey pro ?

10 posts up…

1 Like

Hello All.

I was migrating from one Homey Pro to another Homey Pro. I did a backup of the ole one and disconnected it. I connected the new one and went through the setup and restore process. All went fine but when the new Homey appeared online again some devices were missing. I noticed this from the flows and the list of devices in the HomeyApp on my Iphone. When I click on a device, it tells me unknown device.

any clue as to why this could be happening and how to solve it?

That can have 3 possibilities.

  1. app removed from the appstore so can’t re-install it during restore (you’ve got bad luck, if you’re lucky you can find a source code so you can install it via CLI)
  2. app installed via CLI (you need to manually re-install this)
  3. app installed via community appstore, this is pretty much the same as installing it via CLI for now (you need to manually re-install it again)
1 Like

It is none of the above. Among the devices that are marked as not found there is: 1 neocoolcam switch (the 12 others are there), 1 neoCoolcam sensor among 8 others, Aeotec Wallmote remote, One fibaro device (i have 15 others)…

In that case I would stop the migration, generate a report and send it to Athom. Then powerdown the new/restored Homey and roll back cq powerup to the original Homey to investigate and make a new backup.
Also pls upgradeall homey apps on the your Homey and test that devices before making the new backup.

This is exactly what I have done. I will wait for Athom update.

1 Like

Hi,

I today started a restore to a new Homey Pro.

How long does the restore take on a new Homey Pro? (backup is of a homey2016)

The new Pro has now almost 2 hours a green led which pulses/flashes, the web interface is still on please waiteand the app cannot reach Homey.

Is there any indication how long a restore takes or how to check the status etc?

could take quite some time but 2 hrs is long…
depending on apps to download and an update of the firmware it could take more tan a hour if I remember correct.
if it is not downloading anymore (Blue loading animation) you could PtP and check if it worked.
Else re-power your old Homey and make another backup, Reset the new Pro to Factory (and maybe same Firmware) before you restore the new backup again.

Or send an Log (if possible) to Athom and request assistance from support.

i never saw any blue light.

After selecting the backup (which i made a new backup before pulling the plug on the old homey) is went to green and it is still green (now 1 hour later).

So it is now running more then 3 hours and i only say a green led which pulse/flashes reguarly.

I pulled the plug and started again, this time it went a lot faster but still a disaster.

No app where downloaded or installed, my flows and settings where indeed restored.
I then installed all my apps manually and all seem to work execpt zigbee devices, all devices where listed in the app.

Rebooted Homey again but now none of the zigbee devices are loaded and on dev page the zigbee list is empty again. In the icons the zigbee devices show the loading circle.
After a long wait they are solid but do not work, the dev page see all devices but when i trigger a devies (open door or move a long) the sensors should registrate something but nothing happens. None of the zigbee devices respond.

Also a reboot is not that quick, i expected that the PRO would be a lot faster to start, it takes still sometime more then 5 tot 10 minutes before i can get into the app after a reboot.

No the migration is not going well at all…

UPDATE:

I decided to do the whole process again, so i went back into recovery mode and chose set back to factory settings and start over again.
As a wonder this time everything went as described by others, entered wifi network, chose my (last) backup and started the restore. Now the whole restore process took a little bit longer and homey came back online after 10 minutes.
Almost everything worked this time, only 1 zwave device refused to work (this was also the case on my earlier reply). I decided just remove it and re add it, this worked…
Now all settings, flows and apps are installed and working as they where when i created the backup.

I only had to fix 1 zwave device, the google connection link and the dashboard token.

1 Like