Homey Community Forum

Homey Cameras

Just got v2.2.0 on my Homey and I got an email from Athom announcing the new camera function. However, I can not find the option in the app. And on the Athom website there is no documentation at all. Also nothing on the App portal…

Any ideas?

7 Likes

Hi Pim,
Do you have the new 2.4.0 app?

First you have to update the mobile app to the latest version. I noticed that I just get the feature with my Netatmo Cams. But they’re not showing a live stream.

1 Like

Yes, via TestFlight (iOS).

Will the nest app be updated to use the nest cams?

I don’t think they will… but rather integrate it into this new camera function… But that’s an assumption. So far we don’t know, and apart from the rather short and vague email there is no more info available…

I see that only http streams are supported. Will there also be support for rtsp streams?

I have the same. It seems the Netatmo cams are not supported. There is also no possibility to send a Screenshot or anything :frowning:

Really poor :cry:

The function is very minimal, you need to manually refresh to get a new snapshot.
Would like a history function with all the snapshots or motion+snaphot (like HW)

Also i still hate the long press to “view” a device

have the newest app and updated Homey, but where do you find this new camera thing?

Turn experiments on (virtual devices)

1 Like

Already have that, so it’s Virtual Ip camera??

Thought is was something else :slight_smile:

Come on Athom ! A little bit more info plz !!!

2 Likes

When I put in my up camera by virtual IP, I get an error. Can’t change the port? It’s on :80? But none of my camera’s is On 80

It’s not an experiment anymore now I think?
You just have to add device - select Homey - IP Camera and add the url your camera uses for snapshots.

(my Foscams don’t appear to be supported however, since it doesn’t provide a clean and simple .jpg… :frowning: )

Some examples from Athom would be nice. Not too much to ask for I think.:smiling_face_with_three_hearts:

2 Likes

I had to change the experimental option to on. Otherwise there is no add IP cam option available.
I have 4 foscams (4 different models) they all work. Do you have the correct url?
However no cards visible in the flows?!

So, if I read the announcement right, this is an officially released function, not an experimental thingie. It also states I can pick a camera brand. The experimental option just asks for a URL, that’s it.

My guess is that these are 2 different functionalities, where we have yet to find the officially released one :slight_smile:

Ah, experimental was already on for me :slight_smile:

Wat types of Foscam are you using and what url?

I think I have to use this url:
http://IP:PORT/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=xxxx&pwd=xxxx

That link works in a browser but gives me ‘content-type html/txt not allowed’ in the app :frowning:

FI9900P (http://usr:pwd@ip:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=xxxx&pwd=xxxx&)
FI9800P (http://usr:pwd@ip:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=xxxx&pwd=xxxx&)
FI9831P (http://usr:pwd@ip:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=xxxx&pwd=xxxx&)
C1 (http://usr:pwd@ip:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=xxxx&pwd=xxxx&)