Homey Community Forum

Homey Harmony Hub (v2.0.2)

official
app
#203

My harmony hub is acting up. Started recently (around homey 2.0 update). It gets stuck on the red led every now and then (so doesn’t accept commands). Also noticed that the app in Homey has crashed a couple of times. Anyone else experiencing anything like this?

#204

The red led has nothing to do with homey. It is related to your hub losing connection to its WiFi. I can imagine homey suffering from this as well when it cannot reach the harmony hub due to the network disconnects.

#205

@DavidN I have seen some ECONNRESET crash reports in my email was able to reproduce it and I think I have found the cause of this. Currently, on my development machine, I replaced the autodiscover library this app was using for a different one. And no ECONNRESET has happened for the last 2 days.

I will also check if the red light on your hub is being caused by the Harmony app (check if it somehow overfloods the socket).

Will get back on this soon!

#206

I notice the red led also sometimes (don’t know how much it happens, my hub is out of sight).
So it’s possible this is caused by the app, since several people are seeing the red led that use the app.

#207

@jreenen ,
I know you where busy on other stuff with the app, but any change this is fixed already.
Browsed the complete thread but couldn’t find an anwser.

Cheers
Jan

#208

@Jan_Hilhorst Its good that you come back on this issue as it totally slipped my mind. Would you be so kind to create an issue here: https://github.com/jreenen/com.jreenen.homeyharmonyhub/issues that way I can keep better track of it.

Regards,

Jeroen van Reenen

#209

Done.

1 Like
#210

@Jan_Hilhorst / @DavidN
Still investigating your issues, hope to get back on it soon.

1 Like
#211

A small update, the app had crashed again and has been down for a couple of days (haven’t noticed the red led during that time). Restarted the app again today and now I’m seeing the red led again. I’m guessing it’s related but can’t know for sure. Thanks for investigating! :slight_smile:

#212

In Homey V2.x, for me it is only possible to use ‘start’ or ‘stop’ an activity in the ‘then’ part of a flow. I’m using one flow in which I leave home, but when i’m leaving, the flow works fine, except for the ‘stop activity’ part. It shows a moving ring… Any idea?

#213

Oops, I already found out… it should be ‘start activity’ and then PowerOff… Kind of strange, but it works…

#214

@Jan_Hilhorst found the issue! This will be solved in the next version of the app.

1 Like
#215

Hi @Joep_Vullings ,

The stop activity should also work so I will investigate if something is broken there. Basically its doing the same as starting the power off activity, indeed a bit strange but that’s how the Harmony Hub is designed :slight_smile:

#216

Great.
tnx for looking into this.

#217

@DavidN/@Fire69 After some thorough testing (even used tinfoil to make the hub lose connection) I have found that the library I am using to discover hubs on your home network might cause the app crashes and will overflood your hub with connections.

If the connection of your hub to the wifi network is stable enough it won’t cause this kind of problems, once the connection becomes unstable this app will make it worse by trying to connect in a very aggressive way and eventually smother it completely.

I will rewrite the discovery module and get rid of the external library, this will be included in the next version. Luckily while writing a new app (generic DLNA app) I already did most of this work.

Will keep you informed on my progress.

2 Likes
#218

I’ve got red exclamation marks in the devices using the Harmony Hub app right now. They don’t seem to respond correctly in the experimental ‘devices’ of Homey.

I’m using the experimental V2.0.1 and tried to restart the app, but it didn’t work out.

#219

When you click on a device with exclamation mark, does it state that your hub is offline?

#220

Yep, thats true. Fixed now.

#221

I am working on an improved discovery method that will replace an external library I am currently using. At the moment it considers the hub offline if it didn’t respond on a broadcast message for 5 seconds, and sets the device to unavailable.

I plan to use a different approach for this that only uses the broadcasts for the discovery of new hubs but determines the online/offline state on the socket connection that gets opened right after discovery, this should be a more reliable solution.

Technical details

The broadcast message is send over UDP because this protocol doesn’t have any delivery guarantees a UDP package might get lost. The broadcast is sent once every second if a package gets lost 5 times the app considers the hub offline. WLAN usually have a higher package loss rate than LAN.

1 Like
#222

@jreenen I finally had time to play with the new activities as devices. I added all my activities but it turns out only watching TV is recognized and has the TV device class. It would be great though if at least all activities have the on/off capability so I can use that in flows to check if that activity is currently active (as a condition). Is this something you can implement?