Homey Community Forum

Homey Harmony Hub (v2.0.2)

official
app
#243

Yes, while working on the fix I also detected that since the latest Logitech Harmony Hub firmware they changed the unique id of the hub. I have a version fully working now that would require a deletion of all devices and activities + a repair of those devices. At the moment I am looking into a way to prevent this, although this would take a bit longer for the fix to hit the store, I don’t want to confront everyone with having to re-do all their flows so I think its worth the wait.

I expect to publish a new version late tomorrow or early on the day after tomorrow. After that we need to wait for Athom’s approval.

Sorry for the inconvenience,

Jeroen

5 Likes
#244

Thanks for all the work you’re putting into this.
You don’t need to apologize, Logitech is the o e that should stop messing around with the firmware!

2 Likes
#246

Good job!

1 Like
#247

Strange. I dont have any problems at all

#248

Probably your Logitech Harmony Hub isn’t updated yet to the newest firmware (v4.15.250).

1 Like
#249

@jreenen Just wanted to say that your knowledge and programming skills makes our homes so much more greater than it was before! A big thank you for always holdning us up to date with info and also for all the time you spend with this!

3 Likes
#250

+1

1 Like
Problemen met Harmony Hub
#251

I am currently testing the version that is available for CLI install on https://github.com/jreenen/com.jreenen.homeyharmonyhub/tree/fix/latest_hub_firmware

Currently there is one known issue: if you pull the plug from your hub the app doesn’t detect it. I want to fix it but I might publish this version with the known issue if I can’t fix it today.

1 Like
#252

Looks all good Jeroen, things are back up and running.
I did have to re-add cards to my flows, not sure if this is because I had already uninstalled / reinstalled. Many thanks!

1 Like
#253

Published version v2.0.2 for the app, it’s up to Athom to approve it, after that the store version will be updated. There is 1 known issue: The app doesn’t detect it when the plug is pulled from the hub, will get fixed in an upcoming version.

@Jan_Hilhorst your issue " Homey flow is triggered AFTER the Harmony activity" should be fixed also in this version.

8 Likes
#254

Tnx. And tnx for sticking so much of your time in this.

2 Likes
#255

If you uninstall the app indeed all flows must be recreated after re-installing.

#256

The app is updated to v2.0.2 this should fix the issues on the Logitech Harmony Hub firmware v4.15.250.

Also @Jan_Hilhorst your issue " Homey flow is triggered AFTER the Harmony activity" should be fixed also in this version.

And I have good hope https://github.com/jreenen/com.jreenen.homeyharmonyhub/issues/47 is also fixed in this release.

4 Likes
#257

In some cases a power cycle of your Logitech Harmony Hub and after that a restart of the app might be needed if you still experience issues.

2 Likes
#258

Update fixed the problem, you are a rockstar :)!!

#259

Thank you ! It works great again. Well done !: :+1:

#260

Thank you ! I’am Happy !!!

#261

Powercycled the hub and restarted the app, but it keeps saying “Deze app is onverwachts gestopt”.
Strange thing is I can see that status of the devices connected to the hub, but homey command send to the hub are ingnored by the hub (not seeing the led on the hub reacting).

Testing a flow results in this message:

App homescreen says: (ignore the Utopia flow :smile:, that’s to boost the WAF :smiley:

#262

I have the same error. The TV and Receiver devices work again, but my flow cards shows the error: “Promise was rejected with falsy value”.

Tried to add the card again, but that did not help. I’m on the latest Hub firmware and app.

#263

I have the same error.