Homey Community Forum

Homey Harmony Hub (v2.0.2)

app
official
#21

@jreenen,

Great, thanks for the quick fix!

0 Likes

#22

Hi @jreenen,

In the new beta version 1.3.0 you have to set a repeat count for the numberbasic command.
the lowest accepted value for the repeat count is 1. That means that the numberbasic command is always repeated 1 time. So if i want to switch to channel 1 it actually sends 11

0 Likes

#23

If you would have read a few post back you would know its a bug. And that @jreenen has make a fix for it

0 Likes

#24

@Tolga @tb1962 v1.3.1 has now been submitted this version will allow you to set 0 as repeat value and should fix your problems.

0 Likes

#25

I use the 1.2 Stable version Which i used as a beta before. Unfortunately I still have the same issues.
I use the app to pick up commands from the remote. This way I can Automatically turn off the lights after I turn off the television at night.
It works for a couple of days and then it somehow crashes.
If I reset the app is it will work for a couple of days again.

0 Likes

#26

Use the Candy-app to reset the Harmony-app each day, hopefully that will solve your problem.
Or test the new beta, maybe it fixes your problem also :slight_smile:

0 Likes

#27

@Toon_Vos do you experience the same behaviour on v1.3.1 beta? If so I will try to reproduce it and come up with a fix.

0 Likes

#28

I will install the beta now. If it crashes I will let you know.

1 Like

#29

Hi Jeroen. Nice to have you back.

V 1.3.1 made the flowcard “activity stopped” work correctly. Thanks for that.
Sending a “4” via NumericBasic with zero repeats still results in “44”

0 Likes

#30

Hi @CorvanderNiet I am sorry to hear that as a test could you please setup a new flow that as an example triggers on homey says something with an action that sets your TV to channel 4 (0 repeats) and then press test for that flow. Do you experience that same behaviour then?

0 Likes

#31

I tested with Channel channel down zero repeats. Result: channel down twice.
Also tested with NumericBasic 4 zero repeats. Result: 44.

0 Likes

#32

I tested with the latest update and have no problems. I think its a ir send problem, go in original harmoy app go to devices settings and change the send commands lower.

0 Likes

#33

@jreenen, thanks for your hard work.

0 Likes

#34

@CorvanderNiet Unfortunately I cannot reproduce this behaviour on my side, can you provide me with a screenshot of you flow like this one:

Could you double check the version of this app in your settings menu and see if it states this:

Regards,

Jeroen van Reenen

0 Likes

#35

Thanks to @Tolga 's remark and after a long search I found a Harmony device setting “Herhalingen van opdrachten” (Repetition of commands ?). Changed it from 1 to 0 and problem solved.

Thanks for your effort @jreenen and keep up the good app work :wink:

0 Likes

#36

@jreenen

Any luck with the ‘No results found’ for activities (and after restarting the app now also for the Remote field)? I notice there is an error message, but I can’t see what it shows. Is there any way I can get you that error information?
2018-09-24_1557

0 Likes

#37

@Paul_Kessels, unfortunately, I still can’t reproduce it. Will work on a new version that makes it possible to gather some debug information.

0 Likes

#38

Hi @jreenen, I think it might have to do with the IP Address of the Hub. Last week the electrician installed a smart meter here and all power was shut down for an hour. After power went on again, and both the Hub as the Router rebooted, I had problems with my Harmony Phone App. It couldn’t find the hub. Somehow the only solution was to manually enter the IP address of the Hub to get it connected. So it might be an idea to have the option in the setting to manually enter the IP address of the Hub. Maybe that will solve it.

0 Likes

#39

@Paul_Kessels adding an ip manually would indded be a good idea for this app will start working on that asap. Right now it is using autodiscovery to detect your hub(s) the problems you are facing might indeed be related to the autodiscovery proces not being able to detect your hub. Is Homey connected to the same network as your harmony hub?

0 Likes

#40

@jreenen, yes it is connected to the same network.

0 Likes