Homey Community Forum

Homey Harmony Hub (v2.0.7)

it does nor seem to find my hub
i did a hub ptp for 5 min
i did a homey restart
i did a remove app and install new app (2.07)
i did a new install wifi on hub and a new install wifi on homey
both same wifi network but it dont find the hub
wasent there a way to add it trough ip?

homey 5.0.0-rc.38

it did find the hub 2 or 3 days aggo but when i added it went right offline according to homey
update
yees lol i typed this and did again a hub reboot and then tryed to add it straid away as soon as the led from the hub turn green and it worked
seems that when you wait to long it could not find it anymore.
now i stop fideling with it lol
if its not broke dont touch it lol

Works like a charm here. Thanks @jreenen!

Thanks again for the updated app.
Previously I went to a sideloaded xmpp because of the App Store version of the app makes my Hub sluggish.

Yesterday I installed 2.07 and again, when the Homey non Xmpp app is running my Harmony hub becomes sluggish. I notice it when browsing trough my Apple TV menu, when I disable the app the Harmony Hub becomes way more responsive.

Turns out I do have a problem with 2.0.7 (or with my remote). Any flow that contains ‘activity starting’ gets disabled when I start an activity via my remote or via the Homey App. I haven’t changed anything regarding to key repeats and it was working prior to 2.0.4.

edit:
I thought it might be because I triggered a lot of other flow when starting an activity, but that’s not the case. I made a new flow that only does a small task when an activity is started and that flow is disabled too when triggered.

edit2 & 3:
Yesterday the problem was very consistent, I tried it many many times. Today it works just fine? Maybe it was just an incident. I’ve added a ‘say something’ test. When I start the activity on my remote, the flow is triggered twice.

@ljsvv
Working on refactoring for the upcoming version that should greatly reduce the traffic generated from the app towards the hub. Connectivity will change from real-time to a pull mechanism that periodically checks if anything has changed on the harmony hub.

@Raytestrak
The double flow-triggering only happens when you use the remote?
Did you submitted a manual crash report with this comment on v2.0.7:
Trigger not working