Homey Community Forum

Homey restart and power loss switches off z wave switch

Hi,

When Homey restarts, either nightly from a flow, or when power is lost, my Aeotec Smart Switch turns off and does not power on again. Is there any way to not trigger this behaviour?

I have the always on configuration set to yes.

Can you discover what switches it off, at the device timeline?

Maybe you alr know, but as workaround you could switch it on after Homey started.
Something like this:

Hi,

Yes, as mentioned it is the restart of Homey that triggers it. A restart is not really a good solution since it powers a computer :slight_smile:

I did not say you should restart Homey.
You said the plug switches off when Homey restarts.
So my flow starts at that exact point, and switches the plug back on.

I’ve no solution why the plug gets switched off.
Did you check out the devices’ timeline alr?
Maybe it shows what switches the plug off.
This I mean:

Aha, cool. I meant that switching it on again will still result in a restart (of the computer).

It seems like it is the Aeotec app that turns it off. It does happen whenever Homey is restarted though.

Then I think Aeotec only can help you out.
The app page refers to:

In advanced settings, you also can set Status Restore after power down.

I thought he did so, but isn’t this the same?

That is not the same, there are two different settings, see the first and the last row.

Sorry for the Dutch language in the picture.

1 Like

Well, that setting should be the solution, Jan!

Thanks for the input. Somehow I fail to find the parameter (30) in the advanced settings. I do have the parameter (20) that controls the state of the switch after power comes back, but I believe that configuration is for a power outage of the switch itself.

My issue is that the switch powers off whenever Homey restarts. The switch itself never loses power, yet it turns off.

I have submitted a ticket to Aeotec, thanks for your help.

Nevermind. Btw, not a solution, but, why do you restart Homey at night? That shouldn’t be necessary. Most of the time only restarting ‘suspicious’ apps is enough.

I started to do a nightly restart from a tip on this forum. I cannot remember why though, so I have disabled that flow now.

I will post the solution if Aeotec support comes up with one.

2 Likes