Homey Community Forum

Homey slow boot, red ring

Beste allen,

Ik hoop dat iemand mij verder kan helpen. Ik heb een homey pro. Sinds sw v4 duurt het booten opvallend lang. Ik zie eerst langdurig een oranje cirkel draaien gevolgd door een rode ring. Deze rode ring gaat na ca 20 sec uit en na nog is een minuut kun je in de homey app zien dat alles wordt opgestart. Tot die tijd is homey ‘niet bereikbaar’. Gisteren trof ik homey ook aan met een rode ring. Ik heb hem opnieuw opgestart (ptp) en hierna bovenstaande verhaal en was hij weer bereikbaar. Opvallend vond ik dat alle data (bv energie readings) van de periode dat hij rood brandde ook nog beschikbaar was. Ik heb de adapter al vervangen gezien ik las dat dit wel eens het probleem is, maar geen verschil.
Met enige wanhoop gezien ik veel apparaten heb gekoppeld hoop ik dat iemand mij verder kan helpen. Alvast dank!!

Ik heb hetzelfde gehad met een gewone Homey.
Om deze reden ben ik overgestapt op Home Assistant
Hoeveel apps en devices heb je lopen?
(Vanuit Athom kreeg ik de melding dat ik te veel apps gebruikte)

En we weten allemaal ondertussen dat dat onzin is.
Zelfde onzin als dat ze zeker weten dat “diegene met zoveel apps niet op een normale Homey draait”.
Hier het aantal apps op een early 2016 model :

chrome_2020-03-26_17-18-35

Met een uptime van 124 dagen!

chrome_2020-03-26_17-20-28

1 Like

precies

Dank voor jullie hulp en meedenken! Ik heb het idee dat iets maakt dat homy druk is. Maar ik heb werkelijk geen idee wat. Ik zie een met vlagen een hoge cpu load. (Avg rond de 50 maar ieder uur piek hij boven de 100). In de insights is dit niet te herleiden naar een App.

Ik draai zo’n 25 apps en ca. 175 devices. Wellicht dat mijn hobby te veel vraagt van homey…? Ik ga maar weer verder op onderzoek.

Het valt me ook op dat mijn homey soms herstart. Ik heb een flow gemaakt (als homey herstart, maak notificatie op tijdlijn). Deze triggert iedere ca. 48 uur. Echter, de ‘time since boot’ wordt er niet door beïnvloed. Mocht iemand nog een idee hebben wat dit kan zij of me een richting kan geven waar ik het moet zoeken zou dat super zijn. Tot firmware versie 4 was hij zo stabiel als een huis en draaide hij weken zonder problemen of reboot… Dank!

Dat athom een bepaalde grens stelt met het aantal apps, snap ik wel. Echter dat is wel een hele diepe ondergrens die ze hanteren. Dus zou het aantal wat Athom noemt (ik geloof 15-18) niet al te serieus nemen.

Het aantal dat @Rocodamelsheki heeft draaien is natuurlijk wel weer het andere uiterste. Maar 25 apps moet echt geen probleem zijn.

En denk dat de flows het grootste probleem zijn, waardoor homey druk kan zijn. Bijv veel flows die elke paar minuten getriggerd worden enz enz.

Dat is namelijk de enige reden die ik kan bedenken, waarom er zoveel verschil zit in homeys die gemiddeld het zelfde aantal apps hebben draaien, en toch bij de een problemen geeft en bij de andere absoluut stabiel voor zeer lange tijd.

En nee heb er niet voor geleerd :innocent: maar me persoonlijke gedachte :+1:

Dit herken ik ook.
Ik had ook regelmatig een rode ring en opstarten duurde enorm lang.
Ik heb toen lang getwijfeld om over te stappen op de Pro.
Uiteindelijk besloten over te gaan op Home Assistant.
Ik heb een Raspberry Pi4 gekocht een zwave dongle, Zigbee dongle en een broadlink RM3 IR remote.
De helft aan kosten van een Pro
Ik ben nu sinds een maand over ongeveer en ben er enorm tevreden over.
Ik gebruik sinds een week de Homey er weer bij als dure “LED hub” via MQTT.

Wat ik nu mis tov Homey is de LED ring (zie hierboven) en KaKu.
Ik had een deurbel op KaKu, die heb ik vervangen met een Zigbee button van Xiaomi en gebruik mijn Home Mini als deurbel.

Ik denk ook dat dit voor problemen kan zorgen, toen ik mijn flows wat heb aangepast verbeterde dat toch wel een en ander. Een en ander uiteraard ook afhankelijk van welke apps je hebt.

@Ranney: Je kunt in je browser naar de flow editor https://flow.homey.app/. Dan kun je per flow zien hoe vaak deze wordt uitgevoerd. Als je de muis over een flow beweegt, zie je hoe vaak deze is gestart. Je kunt dan kijken of je de flows die het vaakst worden gestart anders kunt maken, zodat ze minder belastend zijn. Misschien zitten er flows tussen waarvan je niet wist dat ze zo vaak worden uitgevoerd, en waarbij dat ook niet nodig is.

Ahh, dat is super interessant! Ik heb alle flows nagekeken. Op dit moment draait hij weer stabiel. Het opstarten duurt nog wel echt afgrijselijk lang. Na een poos oranje te zijn wordt hij ca. 30 seconden rood en dan komt hij tot leven… Geeft me toch nog wat zorgen…

Qua flows zijn de meeste niet heel intensief. Er zitten er een paar bij die zeer freq. gestart worden. (Bij iedere energie update a 30 seconden). Maar die draaien al ruim een jaar stabiel.

Iemand nog andere tips of adviezen? Zou het herstellen en terug zetten van een backup een zinvolle actie zijn? Of loop ik dan het risico dat dit mislukt / ik dezelfde problemen ‘terug’ zet?