Homey Community Forum

Homey unresponsive after 12 hours.in v2


#21

Indeed we do have some in common:

  • Heimdall
  • KaKu
  • Countdown
  • Fibaro
  • Ikea Trådfri
  • Better Logic
  • Http
  • Virtual devices

There has been the App „Candy“ which identified when Homeys Memory was close to causing trouble and then forced Apps to restart or so … I think it is not (yet?) updated to work w/ v2.


#22

HI all, I have the same problem here, My Homey has been for a week at athom for investigation but they did’n find nothing.
So as far as i could i debugged it by myself.
I disabled all apps , and every day i enabled one app at the time and every hour i checked the memory,

I found out that the HTTP reqeust flow app was the cause.
So after that i checked my flows that using the HTTP request app.
I have 8 flows that runs every 10 seconds for checking status of light (on/off).
After that i disabled all that flows and no memory leaks anymore.

Now i have changed the time for the flow to 30 sec, normaly my homey was online for 1 day now its 3-4 days.

With the HTTP request app i send a simple request and getting a JSON response, filtering it to JSON path and set a variable in the better logic app.
Somehow the response is writing in to memory and causes the fault.

The whole problem with some screenshots and logfiles is send to homey support last Tuesday, they send me e mail that is under investigation by there developer team.


#23

I think it’s best you make an issue so the dev knows there might be a problem: https://github.com/irritanterik/homey-http-request-actions

@Erik is a great dev and always very helpful :wink:


#24

I’ve did extensive performance/load testing in the past and found some Homey-core leaks with it in 2016.
Polling multiple devices every 10 seconds is a bit intense i think, but maybe this is a specific HTTP App > Better Logic App Api combi. If you can PM me a few logs or screenshots i could try to reproduce your problem.


#26

Hi Erik, PM sent with hopefull all needed info.


#27

My homey died. No reboot fixes things, turning upside down doesnt help…:pensive:


#28

@Boudewijn_Snoeren try a new power adapter that can deliver 2 amperes


#29

Would it be possible to see how your request looks like, cause Im trying to do the same, but Im not that technical :slight_smile:


#30

Did you create an issue for this on https://github.com/irritanterik/homey-http-request-actions ?


#31

Sorry but it doesn’t seem to be an issue of the http app as I do not use it but experience the „homey is offline“ as well.


#32

Then did you try another power adapter?


#33

Nope - cause Misses Diva Homey still is alive; I try to teach her adequate behaviour by turning her upside down for a second… then she starts blinking like saying “oh no, I love you, only you and …” well…
I know - Fearful kingdom wont last long - but this seems to be a bug bug bug that’s not gonna get treated (people had that issue months ago already).

So I don’t know - perhaps it may get solved one day, if Athom may exist that long, perhaps my Homey may marry the same bin as Homee did before… experience shows that the latter one may happen as I need to tweak so much w/ Misses Homey that a RaspPi gets more and more attractive in my eyes (Yeah, sorry - I know I shouldn’t look at other Ladies while still married to Homey; but she tells me since years she’s gonna change and all she does is smoking weed obviously and going bankruptcy… not going to carry her through this as my expectations been very high when I bought here on the Smart Home Escort Service “A.msterdam T.est H.ome O.ld M.anufacturies”

Staying curious as I believe in miracles … didn’t see one from the Netherlands since Robin van Persie, but as it’s a small country w/ very small outcome I am really into its quickness to the market and maybe Athom will get a boss that knows how business work and I can find back to her again!
Full of love …


#34

Very long and emotional answer, but that still doesn’t explain why you didn’t try another adapter as advised because that solves intermittent offline/reboot/freeze problems in 90% of the cases…


#35

Curios on this could technically solve that the powered device is not reachable via WiFi?


#36

Well, it’s a simple option which has the least impact and should be an easy test to rule out one cause in the deduction what’s wrong.


#37

There are some tips in the appstore discription:
When in doubt validate your JSON values for flow cards with jsonlint.com. Check your JSONpath expressions with jsonpath.com. If you’re using JSONpath expressions on XML responses, be aware of the XML to JSON conversion. This conversion can be simulated on RunKit.com with the xml2js module.


#38

Okido - you win :smile: I changed it to my iPad adapter (5.1V and 2.1A) now. Let’s wait and see :wink:


#39

Unfortunately this is like reading a foreign language to me. I mean like a Chinese oder Thai! :smile: :man_shrugging:
I don’t get a word of that, Erik - though it sounds very right. Could you pls ehm tell it in “user-only” language somehow? :grin:


#40

Lets first see if @Erik_M_Madsen got his question answered.


#41

Okay - well - just as I thought - it didn’t help as it still occurs. To my understanding - as after a restart it’s up und running again - it has to be a software issue.

Furthermore the flows work, but Homey itself is not reachable via App and DevWebApp says Homey is offline as well.

Strange ?!?