Homey Community Forum

Homey v 2.2.0 mit Kameraunterstützung

  • [Flow] Added image push notification support (Requires Smartphone app 2.4.0)

  • [Experiments] Added Virtual IP Camera

  • [Core] Improved image performance

  • [Flow] Flow tags are no longer created for non-gettable capabilities

  • [Flow] Web Request cards now accept Basic Auth URLs

  • [Apps SDK] Add Image stream support

  • [Apps SDK] Added Device.setCameraImage

  • [Cloud] Improve proxy speed and stability

  • [Google Assistant] Enabling sync now also starts a sync

  • [Core] Minor bugfixes and improvements

Blogeintrag zur neu eingeführten Unterstütztung von Kameras:

Bis gestern hatte ich das noch als Beta.
Jetzt mal ein Update gemacht, aber auch damit sind meine Kameras nicht einsetzbar.
Habe den ganzen Quelltext gelesen,
für Streams habe ich alle Pfade gefunden bzw. nutze sie schon lange.
Nur Bilder, da wollen meine Dingers hier gar nicht.
Mein Fritzfones laufen per RTSP der Kameras.
Falls noch jemand VStar Kameras hat bitte melden.
Laufen bei mir seit Jahren auf allen Geräten.

[https://www.ebay.de/itm/VStarcam-C7816WIP-HD-720P-WIFI-Wasserdichte-IP-Kamera-Nachtsicht-Monitor-GA/283453538239?hash=item41ff25bfbf:g:nYkAAOSwLA9ctWAh]

Es werden nur Standbilder unterstützt und das nur per http bzw. https.

Weiß ich, nur finde da mal den Pfad, wenn die Kamera keinen rausrückt.

sehe nun zum ersten mal ein bild bei meiner welcome von netatmo mit der virtuellen kamera und kann auch nachrichten mit bild versenden, jetzt muss nur noch die netatmo app angepasst werden das es out of the box funktioniert, natürlich auch mit livestream :wink:

Freut mich, wie ist den da der Pfad? Mir gehen langsam die Ideen aus.

Hilft das vielleicht weiter?!

https://www.ispyconnect.com/man.aspx?n=Vstarcam

Danke, kenne ich und hab fast alles durch. Wird wohl das Letzte sein was funktioniert.
Werde mich dann wieder melden.

Ist den Dein Kamera-Model nicht dabei?!

Doch ist dabei:

C7816 __ http://admin:pw@IP:81/snapshot.cgi?user=xxxxx&pwd=yyyy

Nur ist das Port falsch, muß 80 sein,
läuft dann auf dem Mac, iPad und iPhone, aber nicht in Homey.
Seltsam auch, das Nutzer und PW am Anfang und am Ende stehen müssen
Zur Sicherheit den Pfad aus der Homey-eingabezeile kopiert und in Safari eingetragen.
Kein Tipfehler, aber es spielt nicht. Kann nichts zum paaren finden…

Wenn ich im Homey die Experimente ausschalte ist die VD unter Homey weg,
das Angebot seit heute ist also noch die Beta

Versuch mal so http://IP:PORT/snapshot.cgi?user=xxxxx&pwd=yyyy ohne Benutzer und PW vor der IP

Habe ich alles schon durch.

Und noch viel schlimmer, um ganz sicher zu gehen, daß die Experimenteinstellung nicht auf das FW update von heute angekündigt einwirkt, habe ich die Pro mal komplett zurück gesetzt.
Macht besonders Freude da keine Backps ab 2.xx möglich. Das ist für mich wirklich ein Unding.
Bei ca. 60 Geräten alles neu, auch schon diverse Flows, da kommt Freude auf.
Aber Fakt ist, wenn Experimente nicht aktiviert, fehlt die Kamera unter Homey.
Also ist das noch die Beta.
Ich fang also nochmal vom Urschleim an, aber als erstes mit der Kamera.
Wird sich nur nicht viel geändert haben…

Richtig genau wie vor, die Rücksetzung hätte ich mir sparen können.

PS: Ohne USR/PW davor läufts auch auf Ipad, Mac etc. nicht, es muß doppelt dastehen.

Ja, steht auch so in den Release notes:

Richtig erkannt!

Habe ich Dich jetzt richtig verstanden?
Deine URL funktioniert im beliebigen Browser nur nicht beim homey beim hinzufügen einer Virtuellen Kamera, richtig?!

Zu 1. da müßte ich meine Mail nochmal lesen, hab sie leider schon gelöscht.
Vielleicht überlesen, aber bin mir eigentlich ziemlich sicher, auch egal jetzt.

Habe alle Geräte schon wieder installiert, flinker Bube halt.
Nur die Flows sind natürlich weg, aber so lernt man beim wiederholen, hat auch was.

Die URL funktionieren auf allen Apple Geräten, nicht auf Homey

Hab kein direktes Windowsgerät mehr,
nur noch paar Virtuelle Maschinen bei Anfall von Wahnsinn oder Ebikeeinstellung.
W10 ist zu hoch für mich, bin nach XP, dem einzig Wahren ausgestiegen.

Wie ist denn die Fehlermeldung die du beim hinzufügen der IP Kamera bekommst?

failed, reason: Parse Error.

Jetzt kam bei wiederholter Eingabe Could not find that Pair Session.

Wechselt sich ab.

“Could not find that pair session” hat jetzt nicht mit der Kamera zu tun. Ist zwar auchn Fehler aber hier nicht relevant.

Irgendwo muss der Parse Error herkommen. Ich denke bei der Validierung des JPEG Bilds läuft was schief.

Das Schwierigste ist die richtige URL heraus zu finden. Jede Kamera kocht da ihr eigenes Süppchen. Sogar innerhalb eines Herstellers gibt es Unterschiede.
Es gibt nur wenige Hersteller, die den String in der Bedienungsanleitung dokumentieren.
Es geht nur HTTP oder HTTPS. RSTP auf Port 554 funktioniert noch nicht.
Bitte mal das hier probieren:

http://Benutzername:Passwort@192.178.178.31/tmpfs/auto.jpg
Natürlich mit eurer IP überschreiben.

Edit:
Lasst uns doch einen Thread öffnen, wo kompatible Kameras mit der funktionierenden URL gepostet werden können. Der Chef des Threads soll im ersten Post die eintrudelnden Meldungen zusammenfassen. Ich hab leider zu wenig Zeit dazu.

1 Like

Eigentlich sind die Kameras sehr ausgabefreudig, habe damit bisher nirgendwo Probleme gehabt, auch Linux, Android, selbst mit dem alten XP egal welche Software es kommt immer was raus, rtsp sowieso, VLC und irgendwelche Kamerabetrachter…


Das war eine der ersten URL die ich probiert habe.
Der Pfad ist richtig, bis auf den falschen Port.

Gibts so einen Fred nicht schon?
Ich habe ja vor Anfrage schon gesucht, da war sowas, hab mirs nur nicht gemerkt wo.
Und jetzt bin ich erstmal mit alles neu beschäftigt.
Ich suche aber nochmal.
Gerade im englischen Forum gefunden, da hat auch ein Nutzer exakt das gleiche Problem.
Muß also was grundsätzliches sein.

Und noch einer: hab mich also doch nicht verlesen.
Lex

5h

So, if I read the announcement right, this is an officially released function, not an experimental thingie. It also states I can pick a camera brand. The experimental option just asks for a URL, that’s it.

Hier noch eine interessante Seite falls noch nicht bekannt:

https://public-camera.com/en/how-to-connect-ipcamera.html

Einen hab ich noch:
Was muß unter Experimente alles aktiviert sein.
Habe nur VD aktiv.
Nicht daß das mit den anderen beiden Schaltern verknüpft ist.

was noch dringend von den homey Entwicklern realisiert werden sollte, ist eine Vollbildansicht des Bildes bzw. Zoom-Möglichkeit… das ist mehr als mini im Smartphone :slight_smile:

1 Like