Homey Community Forum

Homey V5

Anybody have some more info on which new features will be coming tot homey V5?

It will be changes to the SDK (software development kit) and underlying technologies which should lead to better aka more stable applications.

If there are any features then they are only known to Athom.

1 Like

To me, v5 = zigbee rw. The rest we will see. :smile::smile::smile:

2 Likes

RW = Re-write.

https://community.athom.com/t/important-message-for-experimental-users-upcoming-homey-v5-0-0/32140/2

2 Likes

the zigbee RW is very welcome!

I hope there will eventually be some new hardware! Like a central controll screen, maybe a collab with Atmos Home.

3 Likes

Let’s wait and see. I was hoping on some new awaited features. The signee rewrite is much appreciated as well!

It is the Zigbee rewrite and SDK3 is supporting.

Please read the announcement carefully; it is an experimental release, which will contain bugs and by far not all apps (among others my Aqara app), are updated.

So the devices of those apps will no longer work on Homey v5 until the app has been updated to SDK3.

According to @Undertaker v5 is to be released in the next week:

If it is, it will be as an alpha beta release candidate.

1 Like

There has never been announced a full date that it will be released… When the email was send out to experimental users (link to message), the 7th of July, it said “few weeks” which can mean tomorrow, but also still several weeks away.

I also had a pushnotification for next week release.

And the topic title of the push message contained “next week” . Also got one yes.

May be a stupid question. If app has written to support sdk2 will it have to be rewritten/repaired or somehow chaged to support sdk3? And now I’m not talking about zigbee apps but all other apps for example older apps that dont have active developer.

Then the answer will be no!

1 Like

From what I understand it is yes. To support sdk3 there needs to be adjustments, probably not very much (my guess) but still. V5 however will support both sdk2 and 3. V1 will be removed completely. But correct me if I’m wrong.

1 Like

So :
“Homey Apps that add support for Zigbee devices need to be updated to SDK version 3 before they can be used on Homey v5.0.0.”
goes for all apps? Not just for apps using Zigbee devices?
That would mean that the Ancilla app would also be out of order after the 5.0 update?

No, both 2 and 3 are supported. How it’ll work on the long term, I don’t know.

And yes, if that is a sdk1 app then it’ll stop working. But that is what I understood of it.

So the question was: does ALL apps (besides the Zigbee apps because of the Zigbee rewrite) have to be rewritten from sdk2 to sdk3 ?
Answer is : No!

No, the question is whether all app have to be rewritten to support sdk3. So yes… but I also think in the end support for sdk2 will be dropped… but that is just a hunch and won’t be anytime soon

Just to add my understanding of the situation with V5:

  1. Any app that uses SDK 1 will stop working.
  2. Any app that uses ZigBee will stop working (until it is updated to SDK 3).
  3. Any app that uses SDK 2 but NOT ZigBee will continue to work (until it doesn’t).
  4. If there are any new features in SDK 3 then any app will need to be updated to use those feature.

But this is just how I have interpreted the little bits of information from various sources :grinning:.

6 Likes