Homey Community Forum

HomeyKit

Hello All,

I have a problem with Homeykit and I was hoping someone could help me. It is regarding some Aqara temperature sensors and motion sensors. First I added these devices via the Zigbee plugin for Xiaomi and Aqara. This worked well but I had problems with some sensors refusing etc. Then I found out about deCONZ. I moved al devices to deCONZ and it worked like a charm. But now the next issue appeared. With the Aqara zigbee app temperature sensors would show as temperature sensors in Homekit. But now, with the DeCONZ app, the sensors show up as switches. What could me the issue?

Thanks

If you go to https://developer.athom.com/tools/devices and find the entry for one of those devices, what is the value for the property “Class”, and which capabilities are defined for the device?

Class is sensor.

There are 4 measure capabilities and 2 button ones (button.repair and button.update state) I can set these to false but no luck

I don’t know why it has “button” capabilities, but those are causing the problem. Homeykit has to make a reasonable device mapping from Homey to Homekit, and because the device has “button” capabilities, it is exposed to Homekit as a button (which, in Homekit, cannot have characteristics like temperature, humidity or pressure).

A workaround would be to create a virtual device of type “sensor” with only the temp/hum/pressure capabilities, and use flows to synchronize the virtual and the deCONZ device.

1 Like

Thank you for the explaination. I will contact the developer of deCONZ to ask why these are capabilities in the first place.

Does it support Homey homeyVersion “5.0.0-rc.34”?
When installed the code 200 20 200 does not work.

It should: it’s an SDKv2 app that doesn’t use Zigbee, and those should function without changes on the new firmware. I haven’t tried myself because I’m not inclined to install experimental firmware.

That can have any number of reasons, including a lot of reasons outside the control of Homeykit (for instance using VLAN’s or separate subnets for IoT devices, which may cause problems with multicast). Sometimes it helps switching WiFi off/on on your phone.

1 Like

WiFi off/on did the trick :wink:

Hi

I have some trouble with Homeykit. Using HomeKit on my wall mounted IPad, but it stops working from time to time. Saying that no devices is responding anymore.

I’ve configured it on my iPhone and then sent an share request to the iPad via email, can that be the problem?

Any idea?

Thanks.

Homey’s networking isn’t great, sometimes it loses connections. Try toggling your iPhone’s or iPad’s WiFi when it happens, so it creates a new connection to Homey.

Is there a way to save i.e. the ligh level in Homeykit?
My bulbs return with 100% when I switch them on with Homekit.

Bump

My Homey isn’t recognized by HomeKit anymore. All of a sudden all my Homey devices are not responding:

In Homes’ settings the “Homey” bridge also is not answering:

The settings of the HomeyKit app show all my connected devices:

My other, non-Homey devices are shown in Home App.
I already tried to restart Homey, restart HomeyKit, installed the latest beta v3.0.18 but no success.
Any idea to solve the problem?

Homey Pro, Vers. 4.2.0 | iPad Air 2, iOS 14.2

Try switching the WiFi on your phone off and on.

didn`t solve the problem.
But a PTP-(pull the plug) Restart worked.
Sorry for the inconvenience.

I have a problem i get the error that the code 200-20-200 is no correct.
I switched the wifi off/on several times and i pulled the plug with the same result.
i dont know if it matters but i use a iphone 12 pro max with dual sim.

Are you sure you’re using Homeykit and not the built-in experimental Homekit support?

I have installed the app.
Then i can choose 2 homey’s one has Pro in the name so i choose that one because i have a Homey pro.
I see now als a second on de Homey with a nummer if i choose that one it works.
Thanks

Hi @robertklep, since some days, sadly I do not know exactly since when, the HomeyKit App doesn’t work anymore. When I want to ad or delete some devices in Home Kit and go to “Configure App” the following issue is shown:

I deleted the App and installed v3.0.16. The routine for adding devices in Home Kit worked. Status changes are also displayed correctly between Homey and Home Kit. However, I cannot make any changes in the HomeyKit app afterwards.
I tried also v3.0.17 (Community App Store) and v3.0.18 Experimental. All the same problem.
Homey FW v5.0.0-rc.44
Home-Pod FW iOS 14.2

Any ideas?

Could it be caused by either firmware v5 or a recent update of the firmware? The settings page loads some additional files over the Internet, so your phone needs to have a working connection.

EDIT: I just updated a test version: https://homey.app/a/com.swttt.homekit/test/

Try and see if that works better.

1 Like