Homey Community Forum

Homey's "is playing"-card for Sonos doesn't work after ± 2 weeks

I have a flow for my bathroom, that checks (when motion is detected), if my Sonos is playing. If not, it starts the latest source and pauses efter 10 minutes.

After about two weeks (I have not been able to time it perfectly yet), the “is playing” check is suddenly failing, even though it’s definitely not playing. Restarting the Sonos speaker doesn’t fix it, so it’s something in the (Sonos-app on) Homey that fails.

Anyone else who also notices this? And if yes, anyone who has found a solution? The only way I can seem to fix it now, is by removing the Sonos-speaker from Homey and adding it again. This is just quite a hassle for the different flows, because the “new” device has to be added again.

What version of the Sonos app do you use?

I’m using V4.2.0

I can’t remember if I tried to restart the app, so I’m going to try that when I get home.

I use the Beta version 5.0.7. and it works good and more stable here.
You have to re-include your speakers after installing 5.0.7.
It lets you group/ungroup speakers and switch to line-in on a Connect and more.
Check it out in the Homey app store.

I currently only own one speaker, so it’s fine for me to try the beta, thanks! I’ll probably return in a few weeks, if it happens again with the “is playing” card.

I’ve had similar issues with the volume card.
The flow sets the louder volume in the morning and quieter in the evening. Saves from shouting in panic “Alexa, volume 3” when sonos starts blasting music at night:)

It’s working after removing the sonos app and reinstalling to the newest version.
I guess I needed to do it twice already, Sonos app could have been a bit more stable.

I didn’t even consider the fact that all cards could’ve stopped working, since it stops after “is playing”! Let’s hope the beta is better :smiley:

I have same problem with isPlaying. It is always FALSE.
I had 4.2.0 version and it worked fine. Then I updated to latest beta and it seems Mac Sonos app updated Sonos firmware and isPlaying doesn’t work anymore.

PS. I re-added Sonos speaker of course.

I must admit that the beta app seems almost worse than the previous one. Even though the flow stops when it’s playing (when I test it in the app), it still seems to change the volume at times (when motion is detected > volume to 30%), which it shouldn’t do if the speaker is playing.

I am considering going back to 4.2.0 and just re-adding the speaker every time it stops working.

Athom B.V. v5.0.9 - 18.04.19 just tested, works fine fore me!

Same here

Oh, it works, but not very stable. My flow should turn off the music after 10 minutes and only alter the volume if the speaker is not playing, but in some way it stops before (stacking the 10-minute “pause” timer) and even lowers the volume to 30%, after we manually turned it up.

Edit: On the other hand, this could have to do with wifi-loss on the speaker, but I don’t know how I should be able to check that, since it seems to happen randomly.

Just updated Homey to latest 2.1.2-rc.3. The problem still exists.
I noticed is-Playing changes to False on middle of second song of playlist.

Of course it’s not the Homey, but the Sonos-app that has to send the right data, but I agree that it still sends the “is not playing” signal sometimes, even if it is playing.

I have the same problem… I have reported it to athom… I suggest that all of you do that so they see thats a real problem and fix it faster!

The problem still exists :frowning:

I have made some new flows, that check if a timer is running, and not if the music is playing (the timer running means the music is playing). This means a lot less requests are made to the Sonos, which could be a reason for not registering the play-state correctly after a while.

Can you show/explain one of your flows? Maybe I can help you simplify it, because since I did the thing with the timer, I had no trouble with this.

When I press a wireless button a flow starts.
It checks if sonos already playing. If it is playing it stops. If not playing it starts playing a playlist.
I don’t think the problem with the flow. In my case isPlaying variable switches to false on middle of second track (but music still playing).

Hmm yea, that’s a totally different flow than mine, that can’t be solved with a timer. Shame the problem still exists. I’m afraid mine will also fail at one point, but it’ll take a lot longer to happen since I don’t check “isPlaying” that much anymore.