Homey Community

Horizon TV Settopbox not connected to network


#1

Hi,

In the info about the Horizon TV Settopbox app is noted that:

“You first need to have the IP-address of your Horizon box. Make sure this is a fixed IP address, or otherwise the device cannot be controlled. You can only control it if it is in the same network as Homey.”

Sounds great but when i connect the Horizon box (Mediabox XL) to the network by RJ45 (normal network cable) my home network gets messed up and my internet stops working because it’s sending DHCP adresses to all connected hardware.

Is the use of this app only possible if you don’t have a normal Ziggo modem and only have the horizon box that also serves as a (router)modem?
I don’t get it… :exploding_head:


#2

A “fixed IP address” doesn’t mean a fixed (cabled) connection, it means that in your home router’s DHCP configuration, you have to make sure that the Horizon box always receives the same IP-address (because otherwise, the app cannot find the device anymore if its IP-address has changed).


#3

I mean that the Horizon box is NOT connected with my router/lan.
IF i connect it (can’t find a wifi option so by lan) it messes with my lan making my hardware (IE. Nest camera’s) not connect with the internet anymore.

There are only 2 cables that go into the Horizon and that’s the power cord and the tv cable…
The Horizon box functions perfectly without connecting it to the internet… i just can’t make it work with Homey…

Just to make sure, Horizon = Ziggo Mediabox XL… right?

[EDIT] Yes it is, “Met de Ziggo Mediabox XL (eerder bekend als de Horizon Mediabox) kan het allemaal.” -ziggo.nl [EDIT]


#4

Then kill the DHCP server in ur Mediabox.


#5

Oke, i found some info about it at Ziggo…
still i find it weird that out of the box the Horizon box f***es everything up when you plug in a lan cable.


#6

Oke i discovered that normally you’ll have to run a setup from the Horizon menu so you can choose whether or not it will hand out ip addresses and funcions as a modem and that i probably have a returned version that had not been reset the right way.
Ziggo has several instructions on their website that are not correct…
Anyhow, it’s a very simple setup, after that you can also login with a browser and the ip a address to turn off wifi functionality. (less wifi band pollution)

Thanks for the replies guys!


#7

Good solution :+1: