Homey Community Forum

[HOW TO] Adding a Z-wave device to Homey

Adding a Z-wave device to Homey

This post is to try to help adding a Z-wave device to Homey.
There is a lot of posts on the forums where Z-wave devices could not be added and where is stated that it must be a broken Z-wave chip then. Am not saying that’s impossible but most of the times it can be solved with below steps.
If adding a Z-wave device is failing (for whatever reasons) then please try this below steps.
Please try to follow the steps with love. Like where the PTP states to wait at least 10 minutes before plugging back in, please do so. Also where it states to hold the device VERY close to Homey: 10 meters away is not VERY close, 10 centimeters is.
So please read carefully and follow the steps in the correct order.

Before u start please check if the app of ur device is up to date!
Go to /more/apps and check for updates on the specific app for ur device. Or go to the App-store to see the latest version.

Here we go

  1. PTP
    1a. Hold the device VERY close to Homey! Or bring Homey to the device.
  2. Remove the device from the developer tools (even if it’s not included yes!)
  3. Reset ur device to factory defaults.
  4. Try to add it again.
  5. If no succes start over from number 2.

Disclaimer

Not saying the chip cannot be broken, just trying to help a bit.

P.S.

If u have an addition to this post please let me know so we can improve the Homey experience!

4 Likes

1st check of there’s an update of the app

2 Likes

I’ve never had a device, what did not log on.
In the worst case it was an unknown device.
Follow the tips from @Rocodamelsheki.

1 Like

Added to the OP, cheers.

Some devices need to stay alive during inclusion.