Homey Community Forum

How to prevent one flow to interfere with another flow

flow
#1

Hi

I have a small challenge, and am new to Homey (received my first one, two weeks ago).
I used to have Domoticz through Raspberry Pie, but way to difficult for my significant other, and too unreliable, so switched to Homey.
My normal setup is in Dutch, so I might make some translation errors.

Basically I turn on my living room lights 1 hour before sunset (the turn off automatically at some point at night).
Now I want to turn on the lights as well during the day, if the sunlight goes below a certain threshold.
AND I want to turn them OFF again, if the sun starts shining again.

Basically this setup works, but I want to prevent the lights turning OFF between “the hour before sunset” and it actually turning dark outside.
I’m not sure how to set the flow that turns off the lights when enough light outside to turn them OFF when they actually should be on.

I ASSUME that the Homey Setting called “Date & Time Daytime” runs from SunRise to SunSet.

This is my Setup: (All workflows work as described)

Real World devices:

  • Fibaro Eye (FGMS-001)
  • Several different light switches
  • Nodon Octan Remote Control (CRC-3-1-0x)

Group Devices: (https://apps.athom.com/app/com.swttt.devicegroups)

  • Living Room and Garden (All light switches are included in this VG)

Flows:
-1 Living Room and Garden ON
When “Octan Remote Button 1 is pressed once” then “Turn On - (Group) Living Room and Garden”
-2 Living Room and Garden OFF
When “Octan Remote Button 2 is pressed once” then “Turn Off Light Switch afer x seconds” and “Turn Off Light Switch afer xx seconds” and “Turn Off Light Switch afer xxx seconds” etc etc
-3 Living Room and Garden ON at Sunset
When “The sun sets in 60 minutes” then “Start Workflow ‘Living Room and Garden ON’”
-4 Daytime dark, lights On
When “Fibaro Eye brightness is changed” and “(Group) Living Room and Garden is OFF” and “Date & Time - Daytime” and “Logic Brightness of Fibaro Eye is smaller than 12” then “Start Workflow ‘Living Room and Garden ON’”

And now for the Flow that I need a little adjustment for:
-5 Daytime bright again, lights off
When “Fibaro Eye brightness is changed” and “(Group) Living Room and Garden is ON” and “Date & Time - Daytime” and “Logic Brightness of Fibaro Eye is greater than 16” then “Start Workflow ‘Living Room and Garden OFF’”

Hopefully this whole thing make sense.
How do I prevent flow 5 to interfear with 3?

Many thanks for thinking with me.

#2

Disable flow 5 after sunset…
image

1 Like
#3

In flow 3, add a card to disable flow 5. And create another flow to enable the flow the next day

#4

Thanx guys.

That is THE solution. Facepalming myself for the obvious simple solution I should have been able to figure out for myself.

Now I disable flow 5 from flow 3 and turn it on from flow 4. (flow 5 is only needed if flow 4 has started at all).

1 Like