Homey Community Forum

HTTP GET commandos naar Homey versturen


#1

Hallo Community.
I’ve searched and read a lot of topics but can’t seem to find the right method, or maybe it’s just a syntax problem (hopefully). Maybe someone can help theis newbie out

How do I get a external device to correctly execute a HTTP GET (or POSTor w.e.) to my Homey

In my external device (in this case a Homewizard) I’ve created a IP-switch that, on activation, sends out an HTTP GET ( I’ve used the syntax from the HTTP request flow card app.)

http://192.168.2.10/api/app/com.internet/testbericht

In homey I’ve created a flow called “testbericht”,
in the "WHEN-section I created a HTTP request Flow card; "Incoming GET “testbericht”
and created a then that says… pulse the led in red (for testing)

but it don’t work… :frowning:

What am i doing wrong?

anyone?


  • the reason for this is that a have a few 'homewizard-devices" which don’t match with Homey… I’m gonna replace them, but that takes a while (moneywise). In the meantime, for the transition period, I’d like my doorsensors to tell Homey the’ve activated… I am searching for a fast reliable method to do this preferably internal (no webhooks oid)

#2

When you open that URL in a regular browser, what do you get?


#3

https://CLOUDID.connect.athom.com/api/app/com.internet/testbericht
CloudID can be found in developer system section


#4

And also in the app itself under: settings/instellingen > general/algemeen

testbericht = the trigger to pick it up by homey http flow.
but when you want to send a value with it, use url:
/api/app/com.internet/testbericht/variable
replace “variable” with f.e. “ON” and that will be stored in “value” which can be used in other flows.

oh, and in the when you can use logic:
value = on
then…

tis was my test from yesterday
URL: https://cloudid.connect.athom.com/api/app/com.internet/siri2homey/washok


#5

I also use http Flowcards in combination with HomeWizard and it works perfect. You need to be sure that whitelisting is off when you use homey V2. You also have te use HTTP. HomeWizard doesn’t support HTTPS. When you test the url in the browser you need to get the message ‘ok’.


#6

Got it working,
thx Guys

Dunno exactly what did the trick (I tried whitelisting and different action names in teh flow and in the end I got it right)

Big thanks fot your replies, it told me that it can be done (quite easily) and thus it gave me the motivation to try and retry…

Once I got it right it was quite easy. off course…

I love this forum…

:+1:
.