Homey Community Forum

ID Lock App (v1.2.2)

Just a side track here… Do you have a link for the failing motion sensors issue you mentioned? (sorry)

v1.1.0 is available in the app store

This is the main issue for it: https://github.com/athombv/homey/issues/2267

1 Like

Thank you very much, I see my issues with the fibaro motion sensors are listed. Will wait for update to the fibaro app.

HI Ted,

I’ve installed the the v1.1.0 app and added the ID Lock 150 + z-wave-module. Unfortunately I get the same problem as Baron (I see all information in Homey but can not lock/ unlock the door). My lock is a fresh installation = never tried the GitHub-version.

I’ve tried to install the lock three times, I’ve reseted the z-wave module as well as removing the batteries of the lock - but same result. Any others with the same problem or any suggestiosn what to do?

Regards /Niklas

Hi had this problem with both of my ID Locks on occations. But to be honest, I’m not 100% sure of the exact method to fix it, even though they both work perfectly now.

But, if it’s long distance between the lock and homey, it could be worth a try to temporarily move the homey closer to the ID Lock during the pairing process.

On my garage door, I could not pair at first (quite a bit of a distance there, with several relaying z-wave devices on the way). Moved the homey to the garage, paired it everything worked. Moved homey back to the house. The problem you describe re-occurred. Could still push settings to the lock but not see statuses. After a while this corrected it self.

Hi Baron and thx for your reply,

I’ve been traveling and when coming back home I just noted that the ID Lock 150 is now routing (as you described it would do after some time). Unfortunately, it’s still not working… I can’t lock or unlock and it doesn’t change status when manually locking or unlocking.

Ted, have you had the same problems?

Regards, Niklas

@Niklas_Olsson_Hellst No… but that’s more related to the fact that that I didn’t have an IDLock 150 myself for testing…

In the meantime, @Baron has been supporting greatly by sending me a IDLock 150 that I can use for further development of the app.

Just to check, you have installed the latest version of the app from the app store?
And the steps taken are that you included Homey to close distance of the lock and included the lock there?
Repositioning the lock afterwards?

Hi Ted,

Yes, I have the 1.1.0 app and added the lock with the Homey about 10-20 cm away (three times). One problem is that I can’t remove a lock in Homey - even if I put it in include/ exclude mode or do a z-wave reset on the lock = I have three locks included in Homey now. Homey says it should remove a device when not found after 30 sek, but that’s not working and I receive the following message:

vdevice.drivers.zwavebasic.pair.response_timeout

Maybe this is part of the problem? I have contacted the Homey support about this but no response yet.

Hi @Niklas_Olsson_Hellst,
Did you get a response from Athom support?

The advised way to remove the ID lock 150 is to:

  1. go to Settings > Z-wave > Remove a device
  2. Follow the removal instructions of the ID lock 150 (same as inclusion instructions)

It might be tricky from timing perspective (timeout vs all steps from the ID lock 150)…

On you issue… it could still be a range issue. Do you have other (non-battery powered) Z-wave devices that are able to bridge the distance between Homey and the ID locks?

i have had this problem with my lock one time, then i needed to remove battery and z-wave module and then reset lock, and then do remove device over again, then it worked for me.

Hi, And thanks again Ted for the awesome work so far.
I’ve been using two locks with homey now for a while, and it’s working fine.
Here is my ideas of what would make the app even better.

Should be possible

  • Flow cards for the following

WHEN:
-A door just opened/closed

AND:
-A door is open/closed

THEN:
-Set Doorlock mode
-Set Door relock mode enabled/disabled
-Set Service PIN Mode*

*setting service PIN mode in a flow card opens up much possibilities. For example scheduling the service pin for a special day och in certain situations. I have already tested, if the Service PIN code is set, it will start working again when ever the Service PIN Mode is not disabled. The Code it self, does not need to be set again

Might be possible

  • Log who (which code) opened the lock. And if that is possible, be able to use it in a flow card under “and”*
  • See the PIN codes that is set on the lock**
    *This would enable people to do different stuff depending on which code that was use. For example, also open the garage door if a special code/tag was used.
    **think the feature exists in the lock, but nut sure if there is a good way to present them in homey

Probably not possible, but would be nice

  • Set Pin codes and Service PIN codes
    don’t think the lock it self supports this
3 Likes

Does this app support the new Z-Wave chip for ID-Lock 150? Or is it just for the old 01A version?

Yes, the new Z-wave module is supported

Thanks for the reply.

Do you have plans for adding the option for setting autolock on and off (away mode), using the Flow?
It would be helpfull to be able to use the Door open contact for making a autolock through Flow. But I can’t find the option to use the door open contact signal anywhere.

Hi Ted

Sorry for a late reply.

Yes, I got an answer from Athom. It’s a known issue and they will solve this problem in the 2.0v… So I probably need to wait for a while.

Fyi, I always move the Homey when adding or removing a fix device = it’s not a range problem for me (maximum 10-20 cm between Homey and ID Lock 150)

Hi Johnnie,

Tried it and doesn’t work for me. :frowning:

Regards Niklas

Hi @Baron,

Do you mean that you do not have any issues with battery discharge? I installed the latest version of the app with a 150 lock + Z-wave module and from the start the battery icon shows 1% and the battery alarm is active. The batteries are new. Except that, the rest of the functionality is working very well! Is the battery reported wrong or is the battery really discharged that fast?

Hi,
to clarify.

The issue of the card showing 1% and warns for battery. I have than on one my two locks. But actual fast battery drainage is nothing I’ve noticed so far. Even though battery drains with this lock and z-wave module is widely reported (for other hubs). If that is due to bad implementation, for example ineffective polling of the lock etc by hubs, or something else I don’t know.

The battery warning I, and you, see. Are probably just either a bad pairing or a bug. Ted have also already mentioned before, that the lock does not report a % of the battery capacity. But rather just warns when the battery is low. So it’s a binary switch. I think @TedTolboom Wil change this in some future release.

Forwarding a message @henrikhoe posted on Slack #homey:

People saying its 1% its a bug with the z-wave module. I talked to ID lock a couple of days ago and its coming a free app that will update fw off the id lock, targeting the z-wave module. Its not homey specific, its on ST an all other gateways as well, just thought i should let you know

Once more information is available, let’s share it in this topic

Any new functions added yet? Ex code handling or see who opened the door??

1 Like