Homey Community Forum

ID Lock App (v1.2.2)

Hi JohnnieMalm,

Thanks for the info, the low-battery-bug i don’t care too much about, i can live with that.
I can’t see anything in the changelogs regarding the fix for the drain bug though. I think i was running the 1.1.0 version.

Maybe i’ll have to try again and see if it ok in 1.2.0

Thanks, Reidar

Hi,

An update from my side here. Just installed a new zwave module in my 101 lock that idlock sent me to see if that helped with the drain bug. The lock (101) was now identified as an 150. I will report back if the battery drainage has stopped.

As for the wrong identification, will there be any issues with this?

Regards Reidar

Identification within Homey is done based on the Z-wave product ID…
I might have (incorrectly) linked the new Z-wave module’s ID’s to the ID lock 150 capabilities.
Please let me know if any issues arise from this, ok?

Nice, thanks for sharing @JohnnieMalm!

Did you already test it? Any results noticeable yet?

Yes i have tried, one lock that i didnt have problem with battery, showed 60 % battery, after uppgrade it showd 90. It seems moore correct. It will show fast if it is ok, before this i change battery almost 2 times i week on one of the locks.

Can anyone share a screenshot of what the setup of Key codes in the app? The Tag setup works correctly, but i cannot get the PIN key codes to work. When someone enters a pin the who only shows button. I am assuming that I am doing something wrong in the setup.

I did like this and gets the “who” correctly pushed. I get both codes and button. Haven’t tried tags yet

Any chance for the developer to have a look at the reported issue for this app? Some of them are quite frustrating.

I tried to uninstall and reinstall the app to fix some issues, but forgot to remove the lock from the devices before uninstalling.

When trying to add the lock as a device again I simply just get a message saying ‘status.already_added’, without it being added. Any tips?

@proisland The error 'status.already_added’ indicates that with the previous inclusion attempt, the device is added, but the inclusion was not successfull. You will need to first remove the device by going to settings > Z-wave > Remove any node (and follow the instrutions of the ID lock to remove it).

Once that is successfully done, you can re-add the ID lock to Homey

Did this work for you?
My batteries drain in a week (idlock 101) after switching to Homey (9 months previously on HomeCenter 2)
Would be great if a newer module would solve the problem…

Hi Alexander,

Yes, indeed. There is yet no battery drainage problem with the new Z-wave module. I’ve not changed batteries since install of the new module.

Contact support and they will help you…

Reidar

1 Like

I also get the ‘status.already_added’ error message trying to install my ID Lock (101). I tried deleting it from under the zwave settings, but got a message saying “could not delete a device” or something like that. Any idea on how to fix this?

Version 1.2.1 has been uploaded to the app store, waiting for Athoms approval.

@Tiwas did you try to remove the device first by going to Settings > Z-wave > remove a Z-wave node and then activating the inclusion / exclusion mode on the ID Lock? Timing of actions can be quite tricky…

Yes. Tried that. It says it cannot find it in that menu, while it found another unit that failed.

Ok, so I finally got the lock included, but it doesn’t seem to communicate with it. First I got an error about command sent, but ack not received (or something like it), so I placed another zwave+ device between the homey and the lock (about 7m apart) and now I’m getting this.

Any tips on how to resolve this?

v1.2.1 is available in the app store, but is also causing quite a number of crashes (occurring when the lock is unlocked).

I think I found the problem and implemented a fix on the development branch at Github:

Can someone support to validate that this is fixing the crash by installing this branch (without opening the apps settings page)?

The crash appears to be caused by a missing object, that will be set by the apps settings page.
So opening the apps settings page should also resolve the crash from re-occuring.

How do I install it? Mine’s not working anyway, so might as well by your guinney (sp) pig :stuck_out_tongue: