Homey Community Forum

ID Lock App (v1.2.2)

I got this error code 8f88f696-6337-405d-a357-d53d1458041f. It does not help to enter the setting page. It has occour for about 5 times.

I’ve updated the app to v1.2.2 to resolve the app crashes and requested Athom to approve it ASAP:

Appologies for any inconvenience caused.

1 Like

Thank you for your great app and quick responses!

(I managed to get the current version to work by restarting app and entering settings. However, I did need to turn off all notifications types and remove all tags/keys, and then readding them to make the “somebody” trigger to work properly again.)

v1.2.2 has been released to the app store and should fix the crashes.

Please update the app.

1 Like

Some weeks/months ago the app stopped reporting who unlocked the door. The only update I’ve done is the app. Not the lock. Is this a known bug? Everything looks right in the app settings with correct index number

I believe I mentioned something about that above after an app update. Try removing all entries, closing settings, opening, and re-entering them.

I just installed my ID Lock 150 today, but it registers in Homey as 101. I’m using the same z-wave module as I did in my old lock, but according to ID Lock that should be fine. I also tried resetting the z-wave chip. Same thing happens. Is there a way to force it to recognize as a 150?

I have a id lock 101 with a new zwave chip I side and it’s recognized as a 150 :rofl:

Interesting. So the app only reads the z-wave information? That is something that should be fixed…

Seems like it yes, I had the old zw chip first and the lock was recognized as a 101. Swapped it due to some battery issues and then it was recognized as 150. I’ve written about it earlier in this thread. I guess you can use the 150 functions in Homey as it thinks it’s 101.

What do you mean? I don’t have access to any 150-functions. Only the ones I had with the 101. I’ve logged an issue with the development thread and hope it’ll be picked up. If not, I’ll have to badger ID Lock for a new z-wave adapter :smiley:

After installing a new ID Lock 150 (and z-wave module) today, I’ve tried to add the lock to Homey several times. Unfortunately, after successfully adding the device/lock I’m not able to retrieve any information from the lock or remotely lock/unlock from the app. See attached screenshots.

I’ve tried to reboot the ID Lock app and also to remove + re-add the lock via the Homey app.

Lock firmware version: 1.1.7
ID Lock app version: 1.2.2

Any pointers would be appreciated.

Screenshot_20190623-185449

I wanted to use the discussion thread, but it’s on the old forum and marked as an archive. I hope it’s ok for me to post a question in this thread.

I just got the new ID lock, and as it didn’t register as a 150 with the old zwave module I even got a new one of these as well. The lock now registers correctly. I have access to the different events, like user unlocked the door - but they don’t trigger. They work fine as a test, but not when the door unlocks. Any idea what this might be? I’ve registered the users and codes in the app.

Tried resetting the zwave module? Even when brand new it’s recommended to reset it a couple of times if there’s zwave problems.

Am i remembering wrong or has it never been able to activate/deactivate the service Code with a Flow?
Othwrwise it would be a Great idea to do :slight_smile:

I suddenly have serious battery drain issues. The lock now drains battery in a week. My homey is running the latest rc firmware and the lock is update to latest firmware to
@TedTolboom any clue what happened?

First off, Thanks for the app!

Just got a IDlock 150 today and I´m wondering about the Code/Tag Mappings. the “Index”, Im guessing thats the place for that user on the lock? Will this be changed to support 25 Tags/Pins?

Is the possibility to set codes ever going to be avaible you think?

Got my idlock 150 yesterday, updated it today and then inserted the z-wave module.
Followed the instructions everything went smooth as ice.

I went to settings/idlock added a user index 1 code
made a flow with unlocking door
who tag and text opened the front door
push notification it works like a charm! awesome app thank you :slight_smile:
just a thought that you could have the setup with user in the product description up top :slight_smile:

1 Like

I imagine these are things maybe only the idlock team can change.
First when marked as away having the possibility to actually accept the code before the lock unlocks the door, like getting a push notification with #who wants to enter accept/deny

Second
having the possibility to enter restraint on the users like which day and time they can enter…would love this feature for say cleaning crew, carpenters, mom :smiley: