Homey Community Forum

Ikea control socket won’t connect

I got an ikea tradfri control socket, I tried to connect it several times, one time it homey saw it, but didn’t finish the install, since then Homey has not been able to see it.

Does anyone have tricks for this? I have homey 2cm away from it, but still no luck.

Did u try to reset it?

I hold the button for 10 seconds, that’s the only reset I know about

That doesn’t work either, I tried it, and then tried to install it on homey, but no luck.

Homey have been restartet and without power for some time, but also no luck

Seems like u need to push hard , did u get any feedback from the device after the reset?

Yes I both got the click sound and the led flashing.

This is also why it is strange, im considering trying one of their range extenders, its cheap, and might work better, since they are a new product.

I allso removed some Zigbee devices to stay below the max 20 battery operated pr. power operated unit

How far is the socket from Homey when you pair it?

I have tried 1, 5, 10 cm and even 1 meter, but still no luck, it is very strange, mostly because one time it “almost” happened, except it never finished the installation.

Is the device listed here: https://developer.athom.com/tools/zigbee ?

If not, can you make an IKEA button connect to it?

i don’t have one of the buttons, but im starting to think that my homey has some problems, I delete some Zigbee devices, but now it won’t install new ones, so im doing another PTP

Now I have tried Ikea Trådfri control plug and the range extender, several Xiaomi devices, and nothing can install on the Homey, even with reinstallation of the software for them and restarting the Homey and PTP for 1 hour.

Is Zigbee reset the only way then?

reinstalling the software for Ikea and Xiaomi was a bad idea, I lost all the connections, so might just have to try a Zigbee reset anyway, since nothing is connected

Sound like a good start if all already is messed up. I think you should start a support request with Athom too.

I have send a support ticket to Homey, reset of Zigbee network gives “Could not reset Zigbee: EBADF: bad file description, close: EBADF: bad file description, close" as en error, so that doesn’t work either, so either there’s a bug, or I did something really bad to my Homey trying to fix the problems

This message is normal or at least I had it to when resetting the ZigBee network.
But it indeed resets the network.
The problems with adding and removing devices is due to the limitations on the ZigBee part of homey.
This applies to the device not reachable messages.
But as discussed many times the bug ZigBee update should fix a lot of problems.

Reset Zigbee network, even though it gave an error

Uninstalled Ikea and Xiaomi apps, rebooted, installed them again and PTP overnight.

Now im all the sudden able to add devices again, even the 2 Ikea devices, some of the Xiaomi just need to have the battery removed for a minute, so im on to the big rebuild operation, but it looks promising.