Homey Community Forum

IKEA Trådfri bulbs works, sometimes

Sorry, I searched for a suitable thread but didn’t find any appropriate.

For a very long time I have had an issue where not all my IKEA bulbs turn off according to my flows, different bulbs are impacted but I basically experience this every time when I head for bed. It is not really a big issue but quite disturbing. I have even added the logic that the flow should run twice when triggered, and I can trigger it several times. But no, no difference. The only solution is to enter the Homey app and shut it off manually, which works every time.

If it was the same bulb every time, fine, but now it is different bulbs.

Anyone have the same issue?

It sounds like a common problem a lot of people have, and which has existed for years now: when operating multiple devices from flows, Homey doesn’t send all commands to all devices properly. The result is that not all devices receive the commands, with random results.

The workaround is to add a delay between each device:

  • turn off light A
  • turn off light B with a 1 second delay
  • turn off light C with a 2 second delay

You are everywhere @robertklep!

Yes, I have seen the workaround, and I don’t see any issues using that method.

For some reason it always works better when turning on bulbs, not turning off.
If it is a common issue I guess Athom is aware, and maybe we see a fix for it in the future.

I have given up hope that they are able (or willing) to fix it, since it has existed for so long now.

You have, unfortunately, a good point.
I hope they know about it but chose to prioritize other stuff. Somewhere in s distant future this may be fixed. :wink: