Homey Community Forum

IKEA Trådfri Repeater - adding/routing devices

Hi all,

I added a Trådfri repeater to my Homey to reach some devices in my basement. I cannot seem to get my Xiaomi Temp/Humidity to route via the repeater. I debug via the developer page.

I have tried to:

  • Add the repeater to Homey
  • Move the repeater to the basement (seeing it is still “online”)
  • Remove a Temp/Humidity sensor
  • Add it again
  • Move the sensor to the basement and pressing the button briefly to wake it up

The sensor route is not via the router and the sensor has a hard time communicating. Just for testing I also tried to add the sensor by excluding and adding it again but in the basement close to the repeater but that does not work.

Do you have any input on how do I get my sensors to route via the TRÅDFRI router?

Unpair the sensors from Homey and re-pair them from the location where you want to use them (so don’t pair it close to Homey and move it afterwards). That goes for any device, so if you’re moving the repeaters around, wait a couple of hours before trying to add new devices to the Zigbee mesh can settle.

There is no way to actually force the use of specific router devices.

Ok, thanks. I will try that again now that I know it’s the supposed method…

As you can see I allrady tried that. This is how i did:

  • Removed the device from Homey
  • With the device within cm from the repeater (in the basement), I started the “add new device” in Homey and selected my device
  • Waited for about one minute but Homey did not discover any new device

…so I thought it was the wrong way :wink: I will try again and report back.

Did you wait a couple of hours for the mesh to settle? Also, don’t pair the device “within cm from the repeater” unless that’s going to be its actual location.

Thanks for your efforts to help out, really appriciate it.

The reason I put the sensor close to the router (or Homey) when I pair is because it says so in the documentation. Plus I have never sucessfully paired a sensor to Homey from a far distance.

I am not sure about at what point the Zigbee mesh needs to settle, is it after removing the device or after adding the device before I try to add additional devices?

I have tried adding the sensor again, by first removing it and then within proximity to the router, trying to add it again with no sucess (I like to see it get routed first, then I can try adding the sensor from its intended location in the next room in the basement). So I don’t seem to be able to add the sensor while in the basement, but I can add it when close to Homey. But I did not let the network settle yet either.

I will try again in a couple of hours to see if settling the network helps. The sensor is currently excluded and I have tried adding it while in the basement but with no luck as before.

The network has to settle when you add or remove Zigbee router devices (like the IKEA repeater). Allow some time for the new router, and the existing ones, to find each other and build up connections.

It turned out that the signal from the repeater was too weak. I tested to move the repeater closer to homey and sucessfully added sensors that routed through it. I then added a second router to the basement that routes through the first router and I then managed to add sensors in the basement.

Lessons learned: Zigbee (or IKEA Trådfri repeater) signals are not very strong at least not when traversing floors in a house. My setup is now Homey on 2nd floor, repeater on 1st floor and repeater in the basement. Zigbee sensors are all on battery so they are not routing themselves.

Thank you @robertklep for your help and patience

For others that this is as confusing as it was for me (makes perfect sense now though):

  • Add mains powered devices first (starting with devices closest to Homey)
  • Lastly add battery powered devces (devices should be added in their intented location as it helps with building their route upon added. If a sensor fails to be added your network is to weak, add routing devices between)
  • Zigbee tools at Homey Developer Tools helps you see your network routing and test devices

This is how I see it, please add/or clairyfy if you have other experiences. Settling the network was quite fast (even instant) once the signals were strong enough, my Zigbee network is about 10-15 devices.

1 Like