Homey Community Forum

iKettle App verschwunden

Hallo zusammen, ich habe heute meinen Homey aus einem Backup wiederherstellen müssen. Nach der Wiederherstellung habe ich festgestellt, dass die iKettle App nicht wiederhergestellt wurde. Dachte ich, nicht so schlimm, kann ich aus dem Store schnell nachinstallierten. Musste leider feststellen, dass die App weder im App Store noch im Community Store vorhanden ist. Die App war von Atom. Hat jemand eine Idee wie ich diese App auf den Homey installiert bekomme?

Auf Github noch zu haben.

2 Likes

Ob die App dem FW-Upgrade v5 zum Opfer gefallen ist?
Ganz nach dem Motto: Die hat eh kaum jemand genutzt also lohnt es sich nicht die App für v5 anzupassen. Wäre scheinbar nicht die erste App.
Hast Du Athom angeschrieben?

2 Likes

…ist auch meine Vermutung. An die App hat auch bei GitHub schon lange niemand mehr Hand angelegt

1 Like

Ich habe die App bis heute morgen noch im Einsatz mit v5. Hat wunderbar funktioniert.

Habe versucht die App über CLI zu installieren. Leider ohne Erfolg. Kann jemand mit dieser Fehlermeldung was anfangen?

Habe Athom angeschriebenen und folgende Antwort erhalten:
" Hi Andre,
Thank you for reaching out to us, I’m sorry to hear about your issue.
Unfortunately this app was discontinued, there is no possibility to install this as the app is no longer available.
I am sorry for the inconvenience.
Best Regards,
Boaz
The Athom support team."

Geiler Support, jetzt habe einen Wasserkocher für 100€ da stehen und kann ihn nicht mehr mit Homey steuern, wobei der mit v5 einwandfrei funktioniert hat. :weary:

Was ist das für ein Backup-System, das nicht den ursprünglichen Zustand wiederherstellt, sondern nur die Apps, die aktuell im Store vorhanden sind. Und dafür wollen die noch Geld haben…

Versuch mal die alte Athom CLI Version zu installieren und dann die App zu installieren.

sudo npm install -g athom-cli@1.0.42

Dann cd in den entsprechenden Ordner.

Dann athom project --install

Athom hat in den neueren CLI weitere Validierungsregeln eingebaut.

iKettle ist noch bei SDK V1, wir sind bei V5 auf SDK V3.

Die Pflichtangaben in der app.json kannst du unter folgenden Link nachlesen:

Auf Anhieb sehe ich, dass z.B. die SDK Version nicht angegeben ist.
Scheint jetzt aber kein allzu großer Aufwand zu sein die App V3-fähig zu machen. Ist eine relativ „schmale“ App

1 Like

Ist echt ’ne Frechheit! Kann echt nicht sein! :face_with_symbols_over_mouth:
Auch wenn es vielleicht nichts bringt, aber ich würde denen noch eine saftige Email oder einen Brief schreiben. Vor allem würde ich mich mit der lapidaren und unbegründeten Antwort nicht zufrieden geben.

@Max_Menther, scheinbar bist Du ja rel. fit im Programmieren. Sollte @lirand das nicht hinbekommen wärst Du dann bereit die App anzupassen? Die könnte dann für alle User im Community App Store veröffentlicht werden.

1 Like

Programmieren kann ich ein etwas. Nur leider nicht JS, so dass ich solche Projekte nicht managen könnte.

2 Likes

Habe ich gleich gemacht, bin auf die Antwort gespannt…

Danke @Max_Menther, leider will er mit der Version 1.0.42 die App gar nicht installieren.

@lirand Mach mal den Login und installier die App. Du bist nicht eingeloggt.

Athom Login als Befehl (Hast ja nun die alte CLI Version, daher ist der Befehl nun etwas anders)

Der CLI müsste aber installiert sein. Er meckert nur, dass du nicht mehr unterstützte Pakete installiert hast

1 Like

Ansonsten vllt einfach lieb @Shakesbeard fragen. Er ist DER Experte für Wifi/Lan Geräte.

Ich versuche mich heute Abend mal etwas dran. Vllt kriege ich den Code angepasst, damit die Validieren durchgeht. Versprechen kann ich nichts.

1 Like

Leider will er sich mit dem Befehl “Atom login” nicht anmelden.

Vielen Dank für deine Hilfe! Wäre super, wenn du das hinbekommst.

das scheint alte cli zu sein. du brauchst “homey”

1 Like

Mit “homey” habe ich schon probiert. Bekomme leider Validierungsfehler.

Schwer zu sagen ohne die Code Basis zu kennen.
Das ist aber ein SDK v1 app. Falls du schon auf Homey v5 rc bist kriegst du die garnicht zu laufen.

1 Like

Danke für die Hilfe. Ja, das ist SDK1. Die App hat aber mit v5 gut funktioniert. Nach einem Backup möchte ich die App nur wieder haben.