Homey Community Forum

I'm stuck with the association of nodOn and nano dimmer

Hello guys,

Me again :grimacing:
First time i need association and i cant get it to work.

I have an NodOn octan in my zwave network and my nano dimmer.
In the octan remote i set in group 2(first button) 1,74 but nothing happends, of course i set the remote in learning mode.
Do i have to set settings in the nano dimmer also?, or is there a different dimming channel.

Thanks for youre time again :flushed:
Octan remote


Nano dimmer

nodon remotes by default only work in 1 of 3 ways
Scene activation (99% of the device’s don’t work with this, meant for controllers like Homey) (default)
Dimming control (upper button = higher, lower button = lower)
On/off (upper button = off, lower button = on).

The latter 2 are by default not used as that limits the triggers in Homey from 16 (/infinite with sequences) to 4 triggers in both cases, if you do want to use it (for direct association) then you will have to change the setting(s), and the scene activation will disable (no 2 modes can be active at 1 time per pair of buttons) so you’ll have to make compromises.

Ah oké phieuww.

I thought it is possible on/off and dim.
The button has 4 buttons so it is a restriction from homey pfff.

Using only the dim function is then the best case i think.
By the way that i know for the future it is also not possible with an other remote. On/off and dim.

No, actually it is a restriction from NodOn ;p nothing I (the developer) or Homey/Athom can do about, it is just how the remotes work (probably also one of the reasons why they stopped supporting the z-wave devices themselves).
It is of course possible to dim and/or turn on/off, but it will disable the scene activation (function is selectable from the advanced settings), there are flow trigger cards also for these functions, as long as you keep Homey’s id in there too (1), which is the reason for Homey’s ID being in all groups, just not as many.
It is purely NodOn that has this, other brands usually have no trouble using both scene activation and other ways of control together.
Just read the NodOn’s manual, it will all be in there.

Oke thanks for youre reply, now it is almost working like I want and I have to accept it then.

I have vreate scenes for button 1(on) 3(40%1 click, 70%2 clicks and hold 100%)

With button 2 and 4 I can dim up and down as a curve so not only with the + up and -down that’s not possible but it work.

So I learned something again and the associations are not so difficult as I thought.

Thanks guys