Homey Community Forum

Infrared Setup not working

I just recently got my Homey setup and wanted to set up a couple of simple flows with virtual devices to trigger infrared signals (to mute/unmute my TV etc.).
When I got to set up a new Infrared device (From New Device > Homey > Infrared) it lets me learn from my remote, which is pretty handy.
But, after I set up the first button things start to go downhill pretty fast though. The GUI seems broken, the “Test” button is permanently greyed out, even though the button appears as successfully added and can be named. When I go and click “finish” it just proceeds without any errors, but then, when I open the new devices page, it just shows me a blank screen with a message saying, that the device doesn’t have any functionality (I use the app in German, so I don’t know the exact English wording). None of the previously added buttons are there whatsoever.

Is there anywhere around this issue WITHOUT spending additional money on another hub? (I already have a harmony hub, but neither harmony itself, nor the homey integration with harmony allows for single IR commands to be executed via Alexa voice integration) After all, IR is officially supported and listed on every datasheet I’ve ever seen for homey, so at least the base functionality of adding, and using, an IR-Device should be somewhere to be found.

Hi and welcome to the community!

I am having the same problem teaching in a new infrared remote :cry:

Hello, Same here, and the IR function is one of the features that makes Homey so useful. Actually the reason I choose it. IR stopped working after 1.8 something and never been back.
It made me able to controll my heating (for the hole house), soundsystem and ventilation… Now all gone:-( But maybe we are doing it wrong, (the programing) but can not find any posting on the subject. But if you download the Phillips TV app it will control your tv… So the IR is there…

I guess we should file a bug report to Athom. I am having the same issue, and others with IR.

So I did some reverse engineering with one of the TV Presets (Some Sony one, it really doesn’t matter) And I think I have found at least one of the problems.

When adding Infrared devices manually to Homey, the buttons you register yourself count as “extra” button codes, which will not be displayed in the GUI of the corresponding device, since the GUI only displays certain buttons right now (VOL UP, VOL DOWN, VOL MUTE, CHANNEL UP and CHANNEL DOWN). I think it would be much better if one could customize the GUI of custom IR-Devices with the buttons that they themselves deem useful for the specific device.

However, these extra buttons could be used in Flows (which should be mentioned somewhere inside the device GUI at least, if they don’t add customization). However, I still haven’t managed to get the IR sending itself to work so far. (it might just be a range/line-of-sight problem, as I haven’t had the time to try moving Homey closer to the IR-Devices yet)

(I’m sorry if this information is already “known”, it didn’t seem apparent to me at all when first trying to set up a device, but maybe that’s just me)

Hi Otto!

Thanks a lot for investigating!
Maybe we can all together solve the puzzle bit by bit.
I can tell that putting homey close to the receiving device does not change the situation. After unsuccessfully trying to teach in the power button of my beamer remote I did try all angles and distances of Homey and the beamer with no luck. I found a schematic of homey which says it has four IR diodes evenly distributed around the main platine. So my assumption is that the problems are not related to proximity.

Best

Manfred