Homey Community Forum

Infrarood i.c.m. Samsung and Onkyo

#1

Hi all,

I’ve the following issue since i update Homey to 2.0 last week.
Little story to show my situation;

I run Homey with a couple of flows, one of the flows is that we can say “Oke Homey, TV”.
Than Homey switch the TV on (IR) and our receiver (Onkyo TXL-50) to the right HDMI port and a certain volume.
When the tv and Onkyo are off, and we say this command, than everyting goes in to flip mode.
Homey keeps sending a IR, and it lets Onkyo swtich between hdmi channels verry rapidly, this only stops when i restart or disconnect homey.

I also have a couple of flows, that we can active by voice “oke Homey, Playstion” or “Oke Homey, Xbox”.
Wel, ofcourse homey lets Onkyo switch to the right HDMI channel, and if the TV is allready on, than everything is fine.

Tried to reset the Infrared module, but cant find it anymore in the new app, is this removed?

So, the question is, does anyone know what could be wrong, or is this again a bug in the new software?
I kinda sucks, cause a couple of much used flows are now broken :frowning:

#2

In V2 the microphone is standard switched off.
You have to switch it ActiveSync on at the setup more->settingspage at experience

#3

That is correct.

Forgot to tell that i use Google Home mini now for speech.
So the i switched of the mic.
But thats not the problem :frowning:

#4

i found it out.
I removed the responce from the card. So, for example, with the flow, Oke google, ask homey to switch on the tv, the tv is switched on, and Onkyo is switched on to the correct HDMI channel.
Before Homey 2.0 evertyhing worked fine with the responce card in it, Homey Said “Oke, TV is switched on”.

But now this is broken.
When i still have the responce card in it, and ik give the voice command, homey goes in to flip mode.
With the card removed, everything works like a charm.
Down side is, that i now get a responce “oke, you flow is started, you can add a card to your flow” blablabla.

This problem only exist since the 2.0 update :frowning: :frowning:

#5

Little update.

Just tested it as follow.
TV allready on, and than “Oke google, ask homey to switch on the playstion”. In this flow there is still a card that lets homey speak “Oke, The PS4 is ready for use”.
So, the problem with Homey to let him speak only exist when nothing is turned on.

#6

Is it possible to add some screenshots of the flows?
Don’t wanna guess what’s in there and where it could go wrong.

1 Like
#7

Offcourse, this is the flow as it was before Homey 2.0
Now i removed the “Spraak card” and the flow works, only, as said before, you get the odd responce that i can add a card for “spraak” to it.

Note, that the other flows with the same “Spraak card” in it are working fine.
Also when the TV is off.
This is the only problem, when i want to switch the TV off or On, Homey goes berserk.:rofl:

#8

And the last card, emuleer spraak, where do u use that for?
Emuleer spraak is for that Homey acts like if she heard something. To let Homey just say something use the “Say something” card (Zeg iets) or she can go in a loop like u explained.

#9

oooooow crap. Im such a noob :roll_eyes::roll_eyes:
Remove the card, en put back the one you said. Now its allright again.

Im so sorry :(:frowning: :blush:

#10

No problem. But adding a screenie is so much easier for everybody.
It started with IR, that it sucks and yet another bug in Homey and ended when u put a screenie. Cheers m8, no offence. Glad we could be of any help for ya.

1 Like
#11

Awesome!!
Thanks allot for the help m8!! :grinning::grinning:

1 Like