Homey Community Forum

Issue with Fibaro FGS-212

Hi everyone,
I am having an issue with my FGS-212: It’s connected to a striking plate (dry contact), and when activate it it sends 12v power to release the plate. I also have a momentary switch button to unlock the gate manually.
It works … except that the plate is activated “on its own”. I tried different types of parameters, event settings as toggle switch with a flow to turn it off after a while… no luck.
My current parameters are:
|zw_device_class_basic|“BASIC_TYPE_ROUTING_SLAVE”|
|zw_device_class_generic|“GENERIC_TYPE_SWITCH_BINARY”|
|zw_device_class_specific|“SPECIFIC_TYPE_POWER_SWITCH_BINARY”|
|zw_firmware_id|“1042”|
|zw_wakeup_interval|0|
|zw_wakeup_enabled|false|
|zw_group_1|""|
|zw_group_2|""|
|zw_group_3|""|
|auto_off|true|
|auto_off_relay|500|
|switch_type|“1”|
|save_power_state|false|
Any ideas where I can search ?
Thanks

How long is the wiring from the 212 to the momentary switch?

Maybe 25 meters

Hi

https://manuals.fibaro.com/relay-switch/

From the page:
“Length of wires used to connect the control switch should not exceed 20m”

My assumption:
I think this is because there are usually always parallel cables (other circuits) running along with the control circuit. (Or other electrical interference) These parallel cables can induce voltage to the control circuit and therefore a voltage can be seen at the FGS-212 input even though the switch is not actually operated. Therefore the FGS-212 can operate the light on/off randomly. Why this happens is that FGS-212 checks only the voltage of the control circuit to operate the light. In “normal” lighting circuit this does not happen because the lamp needs power to switch on, not only voltage.

How to fix it? Depends on the installation. Shorter wires would be the optimum but usually cannot be made because of mechanical restrictions. If you can you could try somehow try to minimize the interference coming from other circuits or equipment (distance and filtering).

Like I said this is only assumption but one possibility what could be the problem.

Thanks… will check