Homey Community Forum

ITEAD Sonoff

app

#42

I think the mqtt server needs to be up before it is loading the sonoff app.
I had something similar but i have the mqtt on a pi running.
One day the pi was not working and i needed to have the server up and running before i did restart the homey or else it would not make connection.
So what if the mqtt on the homey is up and running after the sonoff app is loaded?
Will it still make connection?


#43

I’ve tried rebooting the Sonoff App while Homey and MQTT broker is running. That doesn’t solve it unfortunately. The MQTT is receiving status updates continuously from the sonoffs but somehow the connection to the sonoff app is broken…


#45

Any idea? popup comes when trying the settings tab


#46

Issue here: https://github.com/robertklep/name.klep.sonoff/issues/16

It seems to be related to devices that were added as “Generic (Tasmota)”. If at all possible, re-add the device with a more specific driver (like “S20” or “Basic”).

Time permitting, I will push a new release of the app soon that will hopefully fix this problem.


#47

Hello there
I’m happy with my new Homey, but it’s missing a video on how to set up Sonoff Basic without having to program it for Homey.
Looking forward to making a video dummies on this as we have many Sonoff modules in the house.

Med venlig hilsen

Steen Thomsen


#48

Sounds great! However, do mention that the method for pairing the Sonoff devices with Homey without reprogramming it will only work with devices that are running an older firmware. Newer devices cannot be paired with Homey anymore and require flashing an alternative firmware.


#49

Thanks for prompt reply, I have ordered hardware for flachning. :slight_smile:
Question: Can I use Ewlink apps after flaching with new software ??


#50

No, you can’t. You have to make a choice between using the original firmware + Ewelink (but not Homey), or the Tasmota firmware + Homey (but not Ewelink).


#51

Hello Robert,

Thanks for putting together this app. I understand it’s still in development but it’s working well so far for me.

I’m trying to get a Wemos D1 mini (flashed with sonoff-Tasmota v6.3) working with homey. For the moment I’m trying to get switch or two connected to the D1 to interact with homey & didn’t have much success with the ‘generic device’ . I can get a single switch working when I select the ‘basic’ module.

Can you suggest the module to try or settings to apply to take advantage of more of the resources of the D1 (e.g. analog input, multiple switches, multiple outputs etc…).

Thanks again,

Leo


#52

There isn’t a driver yet that can properly work with generic modules running the Sonoff Tasmota firmware. I’m working on one, but halted development because I don’t know it any of the changes I make will survive the migration to Homey v2.


#53

Ok, thanks for the reply.


#54

Hey @robertklep - is this compatible with V2?

(most of my apps arent, so not updating yet, but be nice to tick some off the list!!)


#55

I haven’t heard about any issues yet, but since I’m not running v2 myself I cannot definitively state that it will work.


#56

I run several Sonoff T1 /T2 /T3 switches. I have flashed them with the Tasmota firmware and it works very well with the V2.0 app in combination with the MQTT Broker.


#57

Hi,
I am sorry if repeating a question but i cant get past start screen of Homey App (it asks me to register Homey device and sends me to web page)…
I have several Sonoff basic devices which i flashed with Tasmota and I would like to control them with Homey if possible.

How can I register the devices etc…

Thanks
Jan


#58

Can you post a screenshot here (or send it to me through DM)?


#59

Hi Robert, thanks for replying.

Here comes screenshot.

First screen says You dont have any Homeys… and that I can buy one or set-up one.


#60


#61

That’s an issue that is unrelated to the Sonoff app. You apparently haven’t set up your Homey yet.


#62

OK, now I am totally lost.

Or I have to buy a Homey device first and then trough this device to control my Sonoff modules?

Thanks
Jan