Homey Community Forum

ITEAD Sonoff

No problem completely understand.

Will put in an App request for it.

Thanks for the swift reply.

Robert, hi -

Check out the newly announced Sonoff Basic R3.

Sonoff Basic R3

Does that mean it will be externally controllable (open API?) without having to reflash with Tasmota/Ravensystem/etc?

Thanks

Perhaps, but I can’t find a whole lot of info about how the REST interface works. It might be that the interface is against the (Chinese) cloud servers for the Sonoff devices, and not against the devices directly.

Hi Robert.

I’ve a problem to register an Sonoff SV in Homey with Tasmota firmware.

I’ve started a MQTT Broker in Homey, i’ve set correctly the mqtt server in Sonoff and in the log i view the device is connected to the MQTT Server.

When I adding the device in Homey, i insert the 127.0.0.1 for the adress of the server, but the device is not recognized.

Do you have an solution? Thanks for the help!

You need to use the ip address of your homey at the address field.

S,

Thanks.

I’ve try with my local IP address but the result is the same.

What you mean your local IP? What is the ip of your Homey ?

S,

How have you configured the device in the Tasmota config (the module type, specifically)?

The Sonoff app doesn’t support the SV directly, but I think it should work if you configure/add it as a Sonoff Basic (both in the Tasmota module configuration, and with the Sonoff app).

Sonoff SV works perfect if added as “generic tasmota”.

I’ve set my sonoff in “Sonoff Basic” mode and now homey discoveryng the Sonoff :smiley:
It’s work perfectly. Thanks

I bought some sonoff basic switches. Anyone who has ever tried to connect them with the present wall switches successfully?

I mean, would it be possible to use the sonoff as well as the wall switch?

Hello. I’ve bought an AWP07L module, originally have a tuya firmware and with tuya-convert i’ve Upload a tasmota firmware and now is a module with tasmota and work very well.
I’ve correct set my MQTT brocker and in webgui i view the correct powermeter parameter, but in homey app I don’t view the power meter parameter, and is necessary for me for the flow.

I’ve set my module in tasmota-generic.

Thanks for the support

The power meter capability isn’t supported, I’m afraid (it’s shown because the driver knows that the device has power meter support, but actually reading the power meter data isn’t implemented).

You could look at this topic for a possible workaround.

Hi. Found your message when running a search for eWeLink. I recently bought 2 wifi light switches that are controlled with the eWeLink app. I can connect them in Google home, but can’t seem to get them to work with Homey.

Any suggestions?

Thanks. Emile

eWeLink devices are not supported by Homey. Sonoff devices are only supported when you flash an alternative firmware (Sonoff-Tasmota) to them (this may work for other eWeLink-driven devices too, but can’t promise).

Hi Robert,

Thanks for a nice app! I’m using a couple of Tasmota basic switches.

The newly released DIY mode looks very promising. They are talking about LAN access and “works without internet” so I should think this is the way to go.

This is the official documentation;

Hopefully we won’t have to flash these devices soon :slight_smile:

To be precise, here is the good stuff;

The devices auto-connect to SSID “SonoffDiy” and will work offline :smiley:

This sounds really interesting! Would be great to not have to flash them - I have a few old ones that work great but have held off buying new ones due to this!

Is this an update that is coming to all modules or only specific ones?

Sonoff Basis R3.
The device in the docs look a new device?

So it won’t be possible on current devices?

Hi All, i still had 2 devices of sonoff. 1x rf and 1x wifi. Just checked them today if they worked and they do.
Can ad them into the Ewelink app and can use them thru google assistent. I did had an update from 1.06 to 3.01. Does this mean i have that new software now. Does this change anything so it can be used with homey or is flashing still the only option. My knowlegde of this is not so good so sorry if i am asking something stupid :relaxed: