Homey Community Forum

Knmi (Dutch weather, for Homey firmware v5 or above)

This app uses Homey’s location to fetch the weather data, the only parameter required is the API Key from weerlive.nl.

Fetches dutch weather data from the KNMI up to 300 times a day.
There are two options for this app, either you only fetch data when you need it by calling an action card on a flow,
that in turn fires a trigger card for receiving new data.
The trigger card gives you many tags to use in your flow.

Or you can add a KNMI device that automatically fetches new data at 30 seconds after every whole 10 minutes and updates the device capabilities with it.
In the last case you can simply use these capabilities in logic cards at will and you will always have the latest possible data.
So to visualize when new data is fetched:
00:00:30 (30 seconds after midnight)
00:10:30
00:20:30

12:30:30
12:40:30

Additionally you can make use of an on change trigger card for every value available in the device. Each of those triggers has two tags, one for the old value and one for the new value. This means it’s going to be easy to create a flow to close your sun screen when the recap changes from ‘Onbewolkt’ to something else. Do note that the recap data provided in the app is Dutch, it does not get translated. The data that is provided by weerlive is shown unchanged.

This app has come a long way, and I would like to know what you guys think of it.

The latest version (Homey v5 or above) can be found here.

Anyways, I would like to be hearing from you guys what you think of this app.

The repository for this app can be found here, so you can look at the code.

9 Likes

:+1: that would be nice. Hope it will have the same data as darkweather so i have a good dutch replacement ( for me especially daily highest temp … that decide what flow to use )

Yes, that would be very welcome!
Perhaps you can publish it to the Community Store too?
https://store.homey.community/

I have at this time no intention to make use of that store as this app is likely to be accepted by Athom (especially with the driver version with automatic updates).

A few days delay should not matter that much imho.

The community store is for as far as I see it, intended for apps declined by Athom, where the developer disagrees with the reasons for declining the app.

Sure!

Completely offtopic: what are you doing with highest (max) temperature?

Just curious, what does KNMI offer over other weather apps?

KNMI offers a reliable dutch forecast.
Max temp I use to determine when and if to close shutters and open the Sun screen.

A lower max temp will result in closing the shutters at night while a high one will close them for as long as the sun shines on them.

Hi

If the max temp is above 23 that day… my 5 blinds are fully closed staring at 6 am for example ( keep heat put ) …

below 23 … a different program to run ( in the winter its for keeping light out … so only blind 1 and 2 For example)

1 Like

Closing at low temps (at night) I’ll do if the forecasted max temp for tomorrow is below x though.

REgular user here, i am interrested in the app :slight_smile:

This app can now be tested here.

That means that Athoms approval has been given to this app. I have not published this app to live just yet (my choice) as I believe it should have automatic updating capabilities (once every 10 minutes) that can trigger flows on changing values.

Say the current temperature is updated, I want a future version of this app to allow you to have a flow start on a temperature change, or any other capability the driver will have (each corresponding to a metric returned by the api).

Prior to having that driver, you can only request data manually, and have a flow start on receiving that data with tokens that can be used in the other cards in the flow. So for now this app will remain in test only.

You could write a workaround in flows, triggering the fetching of data every 10 minutes and saving the desired values to virtual devices that can then be used in other flows, but that is far from optimal, so I will be updating that.

Update:
I have added the device and driver that update every 10 minutes, but sadly do not have any of the automatic on change triggers working yet. I have implemented then as mentioned in the documentation, but sadly they do not fire when updating a value.

I have a question concerning that issue outstanding. If I do not get a response in due time I guess the only way is to describe all triggers manually and fire them manually and forget about the automatic on change triggers. That’s just a whole lot of code that should not be needed.

1 Like

I have updated this app yet again, it now includes all functionality I see fit for now. If you have any feature requests or if you find any bugs, please let me know and maybe I will be able to help you with those.

The opening post is also updated with the latest details of this app.

@Some1 link is broken

1 Like

No, it is awaiting certification again. When Athom gives their approval, only then will it work again.

1 Like

Sounds promising.
I have a fan blowing in cold outside air at night to cool (and refresh) the room.
Only when outside temp (netatmo) is lower then inside temp (netatmo)

Still needed to figure out a solution not to cool down the room in winter.
Expected day temperature sounds promising!

Nice! I was searching for apps to check the max temp for my shutters.

Will try and install this app! Thnx :+1:

Oh, still broken… will check tomorow :slight_smile:

I think its a shame that atom cannot fix this in there weather app

I posted the last version with the comment that this one may go to live when Homey firmware v5 is published, I got this response:

That is great! We will keep the app in submission for now then. Unless you want it approved so you can put it in test, let us know.

After that I did let them know a test version is nice for those wanting to use the app on the release candidate. Anyways, not sure if they read that on a sunday, so it might also be monday that it will be back.

The test link is back again!

Yes! But now I get a incompatible app version version error when I try to install the app.

Is it only available on homey 5.0?

Indeed.