Homey Community Forum

Kodi [2.5.0]

official

#41

Only reason I can come up with is, since, capabilities are set upon pairing, you’d need to delete and re-add your device in order for the capabilities to successfully register.


#42

Not sure how to share through the app, but I think you mean this:

c6c77abc-11d2-4fc3-8113-c831798e459e

This is me starting, pausing, resuming and stopping on wired keyboard, Homey app and Yatse app.


#43

Did the capabilities change for Kodi-devices going to 2.0?
Because I didn’t have to repair any other devices after the update.

Did a quick repair, everything seems to be ‘normal’ now :slight_smile:


#44

@Fire69
What were the steps of your ‘quick repair’? Just for sake of completeness :). And yes, capabilities were added going to 2.0


#45

I don’t see any weird things in your log, only that you keep losing connection to kodi every 2-3 minutes… Can you tell me a bit more about your Kodi setup? Do you shutdown Kodi every time? Note that Homey polls for a connection to kodi every 10s which means that if you boot Kodi, there could be a delay of max 10sec before Homey picks up a connection to Kodi. If you start a movie within those 10sec it could be possible that events don’t get picked up.

To test if events are fired properly you can create a test flow:
IF: Kodi starts playing something
THEN: Let homey speak ‘test’

If this flow is fired correctly, then your lights should work as well (provided your flow is correct)


#46

I should’ve typed quick ‘re-pair’. :slight_smile:
I deleted my device, added it again and fixed my (luckily only 3) flows :smile:


#47

I just need to say that you made a great app @Marvin_Schenkel ! I just found it and it was simple to install and a lot of options available, now i don’t have to tell Alexa to turn on/off cinema lights every time someone “disturb” me in the cinema! And there a lot of more things to enable/try out, thanks a lot! :grinning::+1:


#48

Thanks a lot for the kind words and the donation :). Will make sure to buy some coffee from it :wink:


#49

Tried what you suggested and everyting worked as it should except for one thing… so I talked to my friend tonight. He also has a Homey, also runs Kodi and only uses Yatse to control. He thought of the possibility that there might be a difference between the pause and play button within the Yatse app. Pressing the spacebar on the keyboard is the same button for pausing and resuming. I’ve come to the conclusion that this is not the case with Yatse. Testing this I’ve narrowed it down to this:

Using Yatse: Kodi starts playing activates flows as they should. So does stopping as well as pausing.

Apparently it is the resuming that isn’t being recognized as starting Kodi, so my lights stay on, eventhough Homey flows tell them they’re supposed to turn off… I guess I’ll have to take my situation to the Yatse developer… Or am I missing a workaround? What do you think?


#50

How about you create a flow:
WHEN: Kodi has been resumed
THEN: Turn off the lights

‘Kodi starts playing something’ is indeed not triggered on a resume action, so maybe that will help. i still find it weird that the Yatse app behaves differently than the key board, but since I don’t own a Yatse control I cannot test this…

Let me know if adding that extra flow solves your problem :slight_smile:


#51

These are the flows I am using now (and have been using, except now I cut out time dependency to not get in the way of testing):

So there’s really nothing to add… Any ideas what else I could test?


#52

Strange… What version of kodi are you running?


#53

Krypton 17.6.0.0 with Horizon skin. I’ll try and contact Tolriq, developer for Yatse if he has any clue. I have to provide both Yatse and Kodi log… I’ll keep you in the loop. Do you, as a Kodi app developer for Homey (assuming that is what you do) use Kodi yourself? And you don’t use Yatse? Then what do you use?


#54

@Bammeles
Ah yatse is an Android app. Though it was some kind of hardware. Yep I definitely use kodi myself. I just have it installed on a raspberry pi and use my TV remote. The only app I occasionally use is Kore. I’ll download yatse and see if I can reproduce your problem! I know they’ve changed something in resuming Kodi as of v18, so I’ll have to check if yatse is working for me. I’ll get back to you when I have some time on my hands


#55

Thank you for your efforts so far. I could have mentioned it was an Android app. Ah, well… I tried Kore once, but I am much happier with Yatse. At least at the time, not sure how good it is now. It might help to know I am running a version of Kodi that supports SVP (Smooth Video Project) through DSPlayer, which gives me 60 in stead of 24 frames per second. Makes everything run much, much smoother. It does require more powerful hardware than a Raspberry Pie though… I’ll get back to you when I’ve had word from the Yatse developer.


#56

Discovered just now my flows aren’t working correctly anymore either.
When I start a movie, I have a flow ‘When Kodi starts a movie’, that’s working correctly.
But for when the movie stops I use ‘A movie is stopped’, this isn’t working anymore.
I changed it to ‘Kodi is stopped’ and it’s working.
Strange thing I noticed (and this is both with Yatse and my Harmony remote) is that in the Homey-app the device is shown as paused.


#57

@Fire69
Yeah I still need to sync the initial state of a device between Homey and Kodi, so sometimes you could see the device as ‘paused’ while you’re playing a movie.

Also, ‘on movie stop’ is only triggered when the movie has ended including credits, not when you press ‘stop’ while watching a movie:

  • On movie stop (when a movie ends, including credits)

Is that what’s going on, or is something broken? Would you expect this event to fire when you manually press stop?


#58

That’s not really the problem, the state changes when playing or stopping, it’s just that it always shows paused when Kodi is stopped.

I don’t know if something is broken, but behavior did change :slight_smile:
I had to change my working flow to ‘kodi is stopped’ because otherwise my lights didn’t turn back on when I pressed Stop.
This wasn’t a problem before when I had ‘a movie stops’
So maybe it was broken before :slight_smile:
Or maybe it’s because it’s showing as paused?


#59

@Fire69
I think the ‘paused’ thing is by design. Sonos devices have exactly the same behaviour. As for the ‘movie stop’, the behaviour has always been as I described above, so it would only fire when a movie ended including the credits (basically without any human interaction), so I find it weird that it worked for you before. Maybe I should rename to ‘a movie has finished’ to avoid any confusion :).


#60

Might not be bad, but that’s your decision :wink:

Weird that it worked before indeed. But it’s ok now, so I’m good :slight_smile: