Homey Community Forum

Kodi [2.6.0]

I tried to add some more Kodi devices yesterday but the app didn’t find them automatically. But it was a breeze to add them manually.

Looks amazing so far!

Have you enabled Zero-Conf on those kodi devices? Description can be found in the readme on the appstore. The app should be able to find them automatically when that option is enabled (provided you haven’t added them already)

Ah, that might be the issue. Actually, I didn’t go through the settings since it was existing installations of Libreelec. I will remove my devices and try to add them automatically.

2.3.0 has just been released to the beta channel :). Could you guys let me know if everything is working as expected?


  • Added support for Homey v2
  • Added integration with the mobile app for v2
  • Fixed a bug where the app would crash on flow actions after kodi had lost connection to Homey
1 Like

Will try to test tonight :slight_smile:

I was very happy succesfully running Kodi on my Windows 10 HTPC, having the Hue lights turn on and off while watching or pausing. Directly after installing the update for the Kodi app a couple of days ago, Kodi app (within Homey) crashed and Homey reported that a notification was sent to the developer. I reinstalled the Kodi app, but adding the “device” to a room, now keeps giving me the error message: invalid_capabilty… I’ve searched the forum, googled an youtubed to no avail. Since I had recently changed a setting in my router, I checked if router settings were the problem by reverting back to http instead of https, but that didn’t change anything. So now here I am asking for your help…

If I have left important details, please ask me what you need to know.

I installed the beta some days ago and didn’t notice any problems.
However, I only use the app to detect if Kodi (on a RPi3 in my living) start or stops a movie. This was working as before.

I’ve done some extra checks now, and noticed that when I open the device in the Homey-app, it says ‘apparaat niet bedienbaar’

As a test, I’ve added the RPi from my son’s room (which isn’t used for Kodi, only for Hyperion to control the leds around his bed :smirk: ) and when I open this device it shows me a media view (start/stop, volume, mute)

So adding new devices seems to be working OK here, but existing devices do seem to have a problem (although this might be linked to this fix in the new RC2-firmware > * [Devices] Fixed a bug where the device would not have any controls)

Never seen this error before… Are you on Homey v2? Or still running 1.5.X? The latest Kodi app only support v2, but I forgot to enforce that.

If you are running Homey v2, please try to add a device, wait for the ‘invalid capability’ error and then submit a manual diagnostics report and post the ID here :).

Also never seen this error before (apparaat niet bedienbaar). Can you please verify whether this issue still exists after upgrading to Homey v2.0.1 RC2? If so, please submit a diagnostics report here.

It’s a general message, I have it on some other devices where it’s normal to receive this message (like a doorbell-button for example, nothing to control there :slight_smile: )
I’ll upgrade tonight and let you know.

Hey Marvin,

Thanks for your quick response.

I am running Homey Firmware Versie: 1.5.13 Does that mean I have to upgrade to a new version Homey software? Can’t I just give you a 1.5 diagnostics report? I am assuming there is also no way to install the previous Kodi app? That worked flawlessly…

Well yeah, the new app uses functionality of Homey that’s only available in v2 and up, which is why the app is crashing on 1.5.13. I can’t keep supporting ‘old’ firmwares of Homey. which is why I always make sure my app is compatible with the latest stable firmware (which is 2.0 at this time).

Your options are:

1 Like

So I’ve upgraded. Managed to reinstall Kodi, I repaired my flows and got everything working again. Super. Thank you, Marvin!

Surprised to find I cannot use my PC to make flows anymore though… Ah, well. Guess I’ll adapt.

One more thing though. I use a wireless keyboard to control Kodi and when Kodi pauses, Homey turns the light on, when Kodi resumes, Homey turns the lights off again. No problem so far. However there’s a difference when I use Yatse remote to resume playing, it doesn’t follow the flow. Using my keyboard it does. Pausing and resuming using the new Homey app, doesn’t have any influence on the lights whatsoever. Any idea how to get this fixed? Am I simply missing something?


Not sure about the Yatse remote, but using the controls on the new Homey app should definitely do something on Kodi. Can you share your flow? Also, when you press Pause on the Homey app, does it actually pause your movie? If it does, then something might be wrong with your flows

Just updated to 2.0.1rc2, still the same message.
It doesn’t matter much to me, I don’t use the Homey-app to control my Kodi (I use Harmony or Yatse), but I guess you’d like to know for other users :slight_smile:

Let me know if you want me to test something.

Flows work when I control play/pause (spacebar) using wireless or wired keyboard. When using either Homey or Yatse app controls the pausing and the playing works, but the lighting doesn’t follow.

I got four flows:

Kodi starts playing/time is between 15.00 & 02.00/turns lights off
Kodi pauzes/time is between 15.00 & 02.00/turns lights on
Kodi resumes playing/time is between 15.00 & 02.00/turns lights off
Kodi stops/time is between 15.00 & 02.00/turns lights on

Very curious what might be causing this. If you need more info, I’d be glad to provide it.

This is really weird behaviour since they both fire the same events and should trigger the same flows. Can you play around with it (play / pause via key board and homey app) and send me a log report via the app afterwards?

Can you post a screenshot of your device overview / kodi device screen? Also, please restart the app via settings, wait for the app to re-initiate and when that’s done (and you still have the same issue), please send me a log. Keen to see if that holds any info…

Just rebooted for the firmware-update so the app was restarted, still the same.
Log: 2db2840d-58d7-4cea-a3bc-71149134835e

Only reason I can come up with is, since, capabilities are set upon pairing, you’d need to delete and re-add your device in order for the capabilities to successfully register.