Homey Community Forum

Latching relay function flow with DG85 motion sensors

I am trying to implement paradoxical DG85 motion sensors in Homey with the help of fibaro smart implant.

Have these around the house that previously lit outdoor lighting and lamp in the bedroom, upon activation (hardwired with holding circuit ).

But now I want to use the motion sensors for so much more but not really succeed with what I want to achieve.
An example is that I want to use these to send a push message to my mobile both when I am at home that someone is coming and that I get a message when I am away that someone is outside the house.

So this is what i build so far but can’t find any solution for the problem stated below.

When : input 1 is open (alarm)

And: presence

Then: Send push notification

The problem is that DG85 flip alarm output relay multiply times so I get a lot of push notifications.

the solution I am looking for is a flow that as the same function as a latching relay (keep relay). When the input to smart implant is false (in my configuration) it will keep that value and only send one push notification. And then create another flow that reset the value after a certain time.

Does anyone have a solution for this?

I think this may work (assume that the flow is named “Handle DG85 motion”):

  • WHEN input 1 is open
  • AND presence
  • THEN:
    • send push notification
    • disable flow “Handle DG85 motion”
    • enable flow “Handle DG85 motion” with a delay of X seconds

Where “X seconds” is the reset time.

You may have to temporarily disable/enable one of your other flows, just until you save this flow, otherwise you’re unable to choose it.

Thanks for quick reply. It’s my first week with Homey and was focusing to narrowly on the problem.

This solution really opened my eyes, a lot :slight_smile:

But I still get 2 push notifications, I do not know why DG85 change state , if it’s some kind of internal check with the dual sensors…

I tested the function many times yesterday and always received two push messages. A little strange though that it runs through the flow twice before moving on to step 2 in “Then”

But it’s still a good enough solution, many thanks!

The device may be sending multiple state change messages in quick succession, which will each trigger the flow before it can be disabled. I don’t think there’s any solution for that situation with Homey.

This is not possible, are you sure, the time the flow is OFF, is long enaugh? You also can try to delay the “send push notification”, 1 second.

It is when there are multiple state changes at practically the same time. In that case, the flow gets triggered twice and there isn’t enough time for the flow to disable itself.

I just tested with this setup:

Flow1:

  • WHEN this flow is started
  • THEN:
    • send a push notification
    • disable “Flow1”
    • enable “Flow1” after 10 seconds

Flow2:

  • WHEN this flow is started
  • THEN:
    • Start “Flow1”
    • Start “Flow1”

I received two push notifications because Flow1 is started twice (from Flow2) at practically the same time.

As far as I’m aware, Homey doesn’t have a “flow debouncer” or something similar to Home Assistant’s “automation mode”.

This is much faster then two messages comming in to Homey from a device. Al lines in the THEN column, are started at the same time, not after each other (like in a row).

Okay, so I tried something different: instead of using Flow2, I triggered Flow1 on MQTT messages using the MQTT Client app. Two MQTT messages sent in quick succession still result in two notifications.

1 Like

OK, then I give up. I used the priciple to debounce a door sensor, and that works well for me.

It could be that your doorbell adds just enough time between sending the two commands for Homey to be able to disable the flow. Perhaps a few dozen milliseconds might already be enough.

May be a hardware solution can help, placing a capacitor on the input of the Fibaro?

Or possibly with the Implant configuration:

1 Like