Homey Community Forum

Location and Presence (Owntracks) - HowTo



I can’t update to 2.0 yet. Using Bluetooth beacons :s


Owntracks works like a charm, I see my geofences and whether I’m in or outside, my geofences get sent to Homey, but my geofence is not set to my user in Location & Presence app, so I can’t use in flows. I’m using private http based on the config in this thread by the way. Any ideas?


Try setting the minimal Gps accuracy to 150. Ik n the Homey app


Working perfectly for some days already, my settings in the Homey-app:
And in Owntracks using Significant changes:

Private HTTP
Host : https://<cloudid>.connect.athom.com/api/app/nl.scanno.owntracks/events/?token=<tokenid from user>
Identification empty

Locator Displacement : 50
Locator Interval : 30


So you went the http approach. Why not the MQTT broker approach? The intro tells the MQTT approach has some advantages and I’m trying to figure those out atm.


Learning the protocol and apps :slight_smile: But for now I don’t need more, don’t need a broker. However, would also like to know how that works… Step by step…


The advantages of MQTT

  • not using Athom cloud
  • MQTT is a energy friendly protocol
  • MQTT has persistence
  • Other applications besides homey can subscribe to the locations messages also.
  • you can see the location of other house hold members in the owntracks app on your phone
  • you can push way points from homey to connected phones (to sync the fences)

The last two points will also be possible for https in the future (showing the location already is available)


Thanks. That might be an addition for the original post. Firing up ssh to the raspberry :wink:


Is it working for you now?


Yeah. Added to the first post and tweaked it a bit more.


I was skimming community and the old forum to decide whether I should use my raspberry or my NAS. Cons of the raspberry: extra wear and tear on my SD card, cons of the NAS: it might have slow responses when it is in sleep mode. I opted for the NAS… Installed, created users (homey, me and the misses) with passwords, disallowed anonymous access, tested with a
/usr/local/mosquitto/bin/mosquitto_pub -h its.my.public.ip -u gerard -P strongpassword -t /sensor1 -m test -d
It’s seems to be hunky-dory, now on with configuring the phoney and the homey…


You can also try the Homey broker app :wink:


Ow, yes. There’s an MQTT broker for the homey as well, cons of that: load on the homey. So… in my opinion that was not an option, but for those of us reading this without either a NAS or raspberry, you could get it to work that way as well. Everything for a working ‘Loacation and presense’ (ow, you just edited the title?)


yeah adjusted it to match the name change of the app :slight_smile:
Load is pretty decent of the broker on homey :slight_smile:


I’m using the CloudMQTT for free and this is also working fine. what is the advantage of using the MQTT Broker on Homey?


Not much…
Just that it is running in your own home (and as such perhaps a bit more secure).

On the negative side is that you have to expose homey to the internet so you can connect from the outside.

Besides that its fun to make and see that it works :slight_smile:


Yes!! I had to add the 150 to the Homey App, I left it blank. I now see that all the problems I had where in the start post, so in the end was just one big rtfm. So a big mea culpa from my side, I’ll just do a walk of shame around the block an let Homey send notifications about it :rofl:


I have checked the first and second option, did somewhere read that.

so: Check for double enter events and check for double leave events are checked in my config.

I’m now wondering if it is needed? because both our configs are working. :wink:


They are tweaks. If you get multiple notifications for enter or leave events, then you can set them. I only gave the enter events set.

Double events can occur due to GPS drif.


I’m glad I got it working, most of my flows rely on presence and I could not get it to work with my new phone. For now I’m happy with http, maybe in the future I’ll try it with MQTT broker once there’s a guide to follow. Took a brief look at CloudMqtt, but found the guide not n00b proof.