Homey Community Forum

Location and Presence (Owntracks) - HowTo


You did replace the [cloudid] with the cloudid value of your Homey? And the the token with the value that is shown next to the username in the settings?


okay, I updated, and after doing everything right and checking the 401 error before asking :wink: :slight_smile: I got ti to work.
awesome! thanks!

1 Like


I’ve implemented Location and Presence as an alternative voor Homey native Presence not working at all.

I’am using Homey 2.x and installed the Location and Presence app on Homey and Owntracks client on my mobile phone (One Plus). Using http and followed instructions for it. Have a geofence Home on the client (and see it in the Homey app).

I have some difficulties:

  1. Using significant change monitoring mode when the latest update is just outside my fence short before I actually arrive at home Homey (off course) will never detect me as being home. How do I solve this?

  2. Even stranger. My household members also have Owntracks client installed and configured with Home geofence (Huawei and iPhone). Now I see two of them in Owntrack as being outside the house, but Homey thinks they are still at home!?
    Updating the position in Owntracks doesn’t help. Neither does restarting the Homey app?

  3. What happens if press Delete data within the Location and Presence app?

  4. I see EY as an - to me - unknown friend within Owntracks? Is this actually the Location and Presence app on Homey?



Joepie, het werkt ineens weer! Ook voor mijn man waar het helemaal niet meer werkte.



When i enter a region in the OwnTracks app. It jumps in to the presence and locatio app in homey but it dissapers in the owntracks app. Is it How it should be?

I would Also like the right link for version 2.0 users, and it would be nice if the desceiption tells the link as well.

I would like to add my girlfriend. Is it the same on her phone as the description says?

Last but not least. Sorry for my bad swenglish


Evening All - I have just moved over to Homey from Stringify and I am really struggling to get Location and Presence working.

I’ve installed Owntracks on my partner’s phone and mine and set up exactly the same GeoFence on both handsets in the Owntracks App. When looking at Owntracks, it correctly shows that we are at home or outside the region

When I look at the overview in the Location and Presence App, more often than not, it shows a blank space instead of the fence name.

I’ve tried everything including uninstalling and reinstalling the apps on both our phones and redoing the HTTPS URL again. I’ve double checked, the radius is set to 150 as per the recommendations in this thread.

I really am not sure what else I need to try, so please could I have some help and advice!

Many thanks



Yesterday things seemed to improve in the morning. The Location and Presence app updated correctly to show that we had left the Home Geofence.

We had to double back on ourselves and again it updated, this time showing we were home. As we left the GeoFence again, everything updated correctly. I was delighted.

When we returned home, it updated again. There was a bit of a delay in it doing so. Also, despite being in the same car, my phone updated about 11 minutes later. (which could have been the settings)

This morning it again updated correctly as we left for work.

However, this evening I have been bashing my head against the wall again. It only updated my phone as being home over an hour after I got home. According to the Location and Presence app, my partner is still not home. The GPS co-ordinates have updated but it never marks him home. I’ve included the logs in case someone can make sense of what is happening - what is interesting is it appears that he is being marked as home in the logs, but that doesn’t shoot through to the Overview:

20190418-21:12:53 We have received a location message
20190418-21:12:53 Set battery percentage for Drey to 94%
20190418-21:12:53 User Drey authenticated
20190418-21:12:53 handleOwntracksEvents: [{"_type":“location”,“tid”:“d2”,“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tst”:1555618348},{"_type":“location”,“tid”:“d1”,“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tst”:1555618338}]
20190418-21:12:57 handleOwntracksEvents called
20190418-21:12:57 received ‘{"_type":“location”,“acc”:100,“alt”:146,“batt”:96,“conn”:“w”,“inregions”:[“Home”],“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tid”:“d1”,“tst”:1555618355,“vac”:200,“vel”:0}’ on ‘owntracks/Tim/httpendpoint’
20190418-21:12:57 We have received a location message
20190418-21:12:57 Set battery percentage for Tim to 96%
20190418-21:12:57 User Tim authenticated
20190418-21:12:57 handleOwntracksEvents: [{"_type":“location”,“tid”:“d2”,“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tst”:1555618348},{"_type":“location”,“tid”:“d1”,“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tst”:1555618355}]
20190418-21:13:09 handleOwntracksEvents called
20190418-21:13:09 received ‘{"_type":“location”,“acc”:16,“alt”:0,“batt”:94,“conn”:“w”,“inregions”:[“Home”],“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tid”:“d2”,“tst”:1555618366,“vac”:0,“vel”:0}’ on ‘owntracks/Drey/httpendpoint’
20190418-21:13:09 We have received a location message
20190418-21:13:09 Set battery percentage for Drey to 94%
20190418-21:13:09 User Drey authenticated
20190418-21:13:09 handleOwntracksEvents: [{"_type":“location”,“tid”:“d2”,“lat”:51.xxxxxxx,“lon”:-0.72xxxxx"tst":1555618366},{"_type":“location”,“tid”:“d1”,“lat”:51.xxxxxxx,“lon”:-0.72xxxxx,“tst”:1555618355}]


Try enabling the inregions setting in the Homey app.


Thanks very much for the suggestion.

I did that last night and unfortunately it didn’t work too well this morning. Our phones were on significant changes mode in Owntracks and didn’t register we had left the GeoFence. I turned them to move monitoring mode after we had left the GeoFence and left them for a while. This seemed to update the Location and Presence app that we had left but didn’t trigger any of the Homey flows for some reason.

This evening, it did register that we were home in Location and Presence but about 10 minutes after we arrived. What was odd was that our location was shown correctly in OwnTracks. This was with Move monitoring mode enabled.

Any further ideas?


I use a Mosquitto MQTT Broker on my raspberry pi. Location and presence of
homey will check my pi for messages. Works prefect. See OwnTracks.org for howto’s.
I turned off Geofence of homey.
You can install MQTT Broker on homey instead of a raspberry pi.


Hi Hullie - thanks for the suggestion about MQTT. I did try playing around with MQTT but have to admit that I really didn’t understand what I was doing and as a result I couldn’t get things working.

For some reason, it seems to have started to pick up on us coming and going. The arriving back into the GeoFence seems to be rather delayed… but it is working. I am gonna try and work out why but I am just happy it is working at present.