Homey Community Forum

Logic + webhook

I have designed a flow in Node-RED, where a webhook is created using mobile IP (fritz.box -> device presence check). With method “get” the URL is sent to homey.
With homee works it perfect since months without any problems.
How exactly does the URL have to be structured in order to work with “logic - a webhook has been received” with homey?
My sample URLs: (event = anwesend, abwesend / tag = anwesend, abwesend
https://homey-cloud-id.connect.athom.com/api/manager/logic/webhook/anwesend?tag=anwesend
https://homey-cloud-id.connect.athom.com/api/manager/logic/webhook/abwesend?tag=abwesend
Where is my mistake :slight_smile:

Unfortunately I don’t know what’s going on so I can’t help you, but I just wanted to say I have the same problem. Following @Rocodamelshe’s suggestion (IOS Presence app (locative)) but for me the webhook flow never seems to be triggered.

Best use event=precense?tag=present
event=precense?tag=notpresent

Rest of the url looks ok

Flows in Homey will look like this:

chrome_2019-06-17_16-14-57

sorry for the second post / topic

Which of the webhooks did you run?

In the webhook it spells precense in the flows presence. Might that be the problem?

If not, remove the cards in the And… and Then… column and add one that sends you a message and the received value to check if the webhook is received.

Guess that was my mistake.
U can also try to make a flow in Homey to send te GET request by picking a logic card stating “Make a web request” . Just to double check

Well, you misspelled it both in the webhook and flow part, so it should work if the example was followed to the letter :rofl:

True that

many thanks for your help…I have found the mistake …it was a problem with Node-RED :roll_eyes: